Page MenuHomePhabricator

codereview.sql not utf-8 clean
Closed, DeclinedPublic

Description

Author: ewetoo

Description:
Running MySQL 5.051a-24 configured for utf8 on a Debian Linux box. Mediawiki 1.16alpha r58426.

Get the following error on loading codereview.sql:

ERROR 1071 (42000) at line 79: Specified key was too long; max key length is 1000 bytes

The culprit is:

unique key (ca_user_text, ca_repo_id, ca_author); in table code_authors

which appears to be too long for my utf8 installation.

Tested the table without the key and the extension will run with broken functionality.


Version: unspecified
Severity: critical
OS: Linux
Platform: PC
URL: http://svn.wikimedia.org/viewvc/mediawiki/trunk/extensions/CodeReview/?sortby=filehttp://svn.wikimedia.org/viewvc/mediawiki/trunk/extensions/CodeReview/codereview.sql?view=log
See Also: T11350: update.php -> SQL error, T6445: Specified key was too long

Details

Reference
bz21407

Event Timeline

bzimport raised the priority of this task from to Low.
bzimport set Reference to bz21407.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Nov 4 2009, 10:42 AM

ewetoo wrote:

By removing it in initial import and then adding it alternatively in phpmyadmin with collate latin1_bin and utf8_bin i can confirm that utf8 encoding breaks the unique key.

demon added a comment.Nov 28 2009, 4:08 AM

Cf bug 9350 and bug 4445

demon removed a subscriber: demon.Aug 23 2015, 4:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 23 2015, 4:03 PM

Is this fixed since its been 6 years since this bug was reported with no discussion for 6 years.

Aklapper updated the task description. (Show Details)Nov 24 2015, 1:33 PM
Aklapper set Security to None.
Aklapper closed this task as Declined.
Aklapper claimed this task.

We don't know but let's assume it is, seeing T11350 and T6445.