Page MenuHomePhabricator

Wikidata "Duplicate references" gadget hangs on saving copied reference
Closed, ResolvedPublic

Description

Using the "Duplicate references" gadget, when I copy a reference and select "insert reference", the "saving" status message appears but the save never completes.

It seems the reference is correctly copied to the new statement but the actual "publish" step does not complete: if I add another reference manually while the "saving" status is displayed on the copied reference, both the manual and copied references are correctly published.

This problem was discussed on Wikidata Project Chat https://www.wikidata.org/w/index.php?title=Wikidata:Project_chat&oldid=1020965740#%22Duplicate_references%22_gadget_hangs and confirmed to be a problem by three editors.

Event Timeline

PKM created this task.Sep 27 2019, 7:24 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 27 2019, 7:24 PM
PKM updated the task description. (Show Details)Sep 27 2019, 7:24 PM
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Terminators: Is this possibly caused by your changes?

Lydia_Pintscher triaged this task as High priority.Sep 27 2019, 7:30 PM
Jklamo added a subscriber: Jklamo.Sep 29 2019, 7:06 PM

Terminators: Is this possibly caused by your changes?

Very very likely

Yup, it uses wikibase.store.(CachingEntityStore|ApiEntityStore) That has been dropped. The code: https://www.wikidata.org/wiki/MediaWiki:Gadget-DuplicateReferences.js

Lydia_Pintscher added a subscriber: matej_suchanek.

@matej_suchanek Is this something you want to have a poke at?
@Ladsgroup What should be used instead?

matej_suchanek added a comment.EditedOct 2 2019, 12:02 PM

Not anytime soon, sorry.

Haros added a subscriber: Haros.Oct 2 2019, 11:58 PM

Just an idea cant User:Matěj_Suchánek/moveClaim.js be changed to support copy the reference it still works.... and today allows moving claims across items....

Its purpose is (surprisingly) to move/copy claims. Why reinvent the wheel? We just need to have this one fixed.

Wostr added a subscriber: Wostr.Oct 6 2019, 7:31 PM
Laddo added a subscriber: Laddo.Oct 11 2019, 11:35 PM

Hello Everybody,
Someone could explain us why a so usefull tools is out of order for a so long time?
The information quality in Wikidata can be (is already) impact by this.
I am a no tech user. I can imagine that it much more complex as I imagine, but just give us news.
Thanks in advance.
Baptiste

agree with Baptiste this is the primary tool for adding sources to more statements in WIkidata

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptOct 14 2019, 7:48 PM

Hello all,
We are working on fixing this issue. Thanks for your patience.

Ladsgroup moved this task from Incoming to Done on the User-Ladsgroup board.Oct 15 2019, 2:28 PM

Fixed. Let me know if you still encounter issues.

Thanks it works ... more than happy ;-)

Fixed. Let me know if you still encounter issues.

Thank you!

Thank you so much !

Lucas_Werkmeister_WMDE closed this task as Resolved.Oct 16 2019, 9:36 AM

Thanks so much !