Page MenuHomePhabricator

nqo.wikipedia: "An error has occurred while searching: We could not complete your search due to a temporary problem. Please try again later."
Closed, ResolvedPublic

Description

Spotted while doing this query: https://nqo.wikipedia.org/w/index.php?title=%DF%9E%DF%99%DF%8D%DF%9E%DF%99%DF%8D%DF%A3%DF%8D%DF%B2%3ASearch&search=user%3AMABot&fulltext=1&ns0=1&uselang=en&debug=true

Error message: "An error has occurred while searching: We could not complete your search due to a temporary problem. Please try again later."

No access to Logstash so I don't know what exactly might be the issue. If someone with access could see if there's any trace there I'd appreciate it.

Thanks.

Event Timeline

Restricted Application added a project: Discovery-Search. · View Herald TranscriptOct 1 2019, 1:34 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Daimona added a subscriber: Daimona.Oct 1 2019, 2:17 PM
message
Search backend error during full_text search for 'user:MABot' after 7: index_not_found_exception: no such index

Seems to happen for every search.

Thanks @Daimona. @Urbanecm @Ladsgroup Could this be caused by the addWiki script failing to do something?

https://wikitech.wikimedia.org/wiki/Add_a_wiki#Search says CirrusSearch should be handled by the script.

Mentioned in SAL (#wikimedia-operations) [2019-10-01T14:33:59Z] <dcausse> created cirrussearch indices for nqowiki (T234326)

Mentioned in SAL (#wikimedia-operations) [2019-10-01T14:33:59Z] <dcausse> created cirrussearch indices for nqowiki (T234326)

That seems to have fixed this as I no longer see the error reported. User:MABot does not exist there so not appearing in the search results is normal for now :) Thanks.

MarcoAurelio closed this task as Resolved.Oct 1 2019, 2:39 PM
MarcoAurelio assigned this task to dcausse.