Page MenuHomePhabricator

Add gender support for several messages
Open, Stalled, NormalPublic

Description

Some messages on translatewik.net are missing gender support when translated to other languages (especially Arabic: every verb has to be with GENDER magic word).

List of messages

  • Growthexperiments-homepage-start-header
    • {{GENDER:1|Start}} here
  • Growthexperiments-homepage-userpage-header
    • {{GNEDER:1|Create}} you user page.
  • Growthexperiments-homepage-userpage-header-done
    • {{GNEDER:1|Edit}} your user page
  • Growthexperiments-homepage-userpage-body
    • {{GNEDER:1|Practice}} editing while building your public profile.
  • Growthexperiments-homepage-userpage-body-done
    • {{GNEDER:1|Continue}} working on your public profile.
  • Growthexperiments-homepage-userpage-button
    • {{GNEDER:1|Create}} user page.
  • Growthexperiments-homepage-userpage-button-done
    • {{GNEDER:1|Edit}} user page.
  • Growthexperiments-homepage-email-button-noemail
    • {{GNEDER:1|Add}} email
  • Growthexperiments-homepage-email-button-unconfirmed
    • {{GENDER:1|Get}} a new link
  • Growthexperiments-homepage-startediting-header
    • {{GENDER:1|Start}} editing
  • Growthexperiments-homepage-startediting-subheader-edit-typo
    • {{GENDER:1|Find}} articles that need small fixes!
  • Growthexperiments-homepage-startediting-subheader-add-image
    • Before adding an image, {{GENDER:1|try}} learning with some easier edits!
  • Growthexperiments-homepage-startediting-subheader-new-page
    • Before creating a new article, {{GENDER:$1|Try}} learning with some easier edits!
  • Growthexperiments-homepage-startediting-dialog-difficulty-header
    • {{GENDER:$1|Try}} some <strong>Easy</strong> suggested edits first
  • Growthexperiments-homepage-tutorial-header
    • {{GENDER:$1|Learn}} to edit
  • Welcomesurvey-subtitle
    • {{GENDER:$1|Help}} us improve your Wikipedia experience by answering a few optional questions.
  • Growthexperiments-help-panel-questioncomplete-notifications-wiki
    • {{GENDER:$1|You'll receive}} a notification here on {{SITENAME}} once there's a response.
  • Growthexperiments-help-panel-questioncomplete-notifications-email
    • {{GENDER:$X|You'll also receive}} an email to $1 ($2)
  • Growthexperiments-help-panel-questioncomplete-notifications-email-unconfirmed-confirm
    • {{GENDER:$1|Confirm}} your email
  • Growthexperiments-homepage-startediting-button
    • {{GENDER:$1|See}} suggested edits
  • Growthexperiments-homepage-startediting-dialog-difficulty-level-medium-description-header
    • For when {{GENDER:$1|you have completed}} some easy edits.
  • Growthexperiments-homepage-startediting-dialog-difficulty-level-hard-description-header
    • For when {{GENDER:$1|you are familiar}} with writing on Wikipedia.
  • Growthexperiments-homepage-suggestededits-select-other-difficulty
    • {{GENDER:$1|Select}} other difficulty levels to find suggested edits.
  • Growthexperiments-homepage-suggestededits-select-other-topics-difficulty
    • {{GENDER:$1|Select}} other interests or difficulty levels to find suggested edits.
  • Growthexperiments-homepage-suggestededits-mobilesummary-footer
    • Volunteers like you have contributed to improving {{SITENAME}} today. {{GENDER:$1|Join}} in!
  • Growthexperiments-homepage-startediting-dialog-difficulty-level-easy-description-header
    • Recommended for your initial steps as an {{GENDER:$1|editor}}.
  • Growthexperiments-homepage-suggestededits-tasktype-shortdescription-copyedit
    • {{GENDER:$1|Fix}} spelling, grammar, and tone of the article.
  • Growthexperiments-homepage-suggestededits-tasktype-shortdescription-references
    • {{GENDER:$1|Find}} sources to verify Wikipedia articles.
  • Growthexperiments-homepage-suggestededits-tasktype-shortdescription-update
    • {{GENDER:$1|Bring}} articles up-to-date using new information.
  • Growthexperiments-homepage-suggestededits-tasktype-shortdescription-expand
    • {{GENDER:$1|Make}} articles longer by finding and adding more information.
  • Growthexperiments-homepage-suggestededits-tasktype-shortdescription-links
    • {{GENDER:$1|Add}} links to other articles.
  • Growthexperiments-homepage-suggestededits-tasktype-description-references
    • {{GENDER:$1|Use}} books, websites, and news sources to validate that Wikipedia is accurate, and {{GENDER:$1|add}} those to articles so that readers can feel confident that what they're reading is true.
  • Growthexperiments-homepage-suggestededits-tasktype-description-update
    • Articles get out of date as time goes on and new events occur. {{GENDER:$1|Find}} and {{GENDER:$1|add}} the correct information so that Wikipedia always contains the current truth.`
  • Growthexperiments-homepage-suggestededits-tasktype-description-expand
    • Many Wikipedia articles are only a sentence or two long. {{GENDER:$1|Find}} more information and {{GENDER:$1|add}} it to make the article more complete.
  • Growthexperiments-homepage-suggestededits-tasktype-learn-more
    • {{GENDER:$1|Learn}} more

(Not gender support but while we are there) growthexperiments-homepage-suggestededits-pageviews needs PLURAL

Details

Due Date
Mon, Oct 28, 11:00 PM
Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterAdd gender to some messages

Event Timeline

Restricted Application added subscribers: alanajjar, Aklapper. · View Herald TranscriptOct 1 2019, 5:06 PM
Dyolf77_WMF triaged this task as Normal priority.Oct 1 2019, 5:07 PM
Dyolf77_WMF updated the task description. (Show Details)
Dyolf77_WMF set Due Date to Oct 10 2019, 11:00 PM.
Dyolf77_WMF changed the task status from Open to Stalled.Oct 1 2019, 5:14 PM
Dyolf77_WMF changed the task status from Stalled to Open.
Dyolf77_WMF updated the task description. (Show Details)
Dyolf77_WMF updated the task description. (Show Details)

@Dyolf77_WMF: Assuming this task is about GrowthExperiments hence adding project tag so someone else could find this task when searching for tasks under that project. Without such project tags, developers will never find this task.

Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 2 2019, 1:38 AM
Urbanecm renamed this task from Gender Support for Arabic to Add gender support for several messages.Oct 2 2019, 10:51 AM
Urbanecm updated the task description. (Show Details)
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptOct 2 2019, 10:51 AM
Urbanecm updated the task description. (Show Details)Oct 2 2019, 10:52 AM
Urbanecm updated the task description. (Show Details)
Urbanecm updated the task description. (Show Details)
Urbanecm added subscribers: Urbanecm, kostajh.

Change 540449 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] Add gender to some messages

https://gerrit.wikimedia.org/r/540449

Tgr moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.
Tgr added a subscriber: Tgr.

Change 540449 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Add gender to some messages

https://gerrit.wikimedia.org/r/540449

Checked in arwiki betalabs.

@Tgr - I did not see the difference in displayed messages (when "How do you prefer to be described?" setting was changed)- does new messages need some additional push or something?

The way I tested:

  • log in to arwiki betalabs
  • in Preferences - User profile change "How do you prefer to be described?"
  • evoke the Welcome survey with Special:WelcomeSurvey?_group=exp2_target_specialpage and compare which messages will display gender support (the steps worked for `cswiki).
Tgr added a comment.EditedOct 6 2019, 9:49 PM

welcomesurvey-skip-btn/ar was updated on Oct 3 to make use of GENDER. Not sure at what schedule translations reach beta; the local message definitely uses gender now.

I tested locally by changing the English messages to be gender-dependent, that worked as expected.

Etonkovidova closed this task as Resolved.Oct 10 2019, 9:21 PM

Checked in arwiki wmf.1

Dyolf77_WMF reopened this task as Open.Oct 16 2019, 3:35 PM
Dyolf77_WMF updated the task description. (Show Details)
Dyolf77_WMF updated the task description. (Show Details)
Dyolf77_WMF updated the task description. (Show Details)Oct 16 2019, 3:38 PM
Dyolf77_WMF updated the task description. (Show Details)Oct 16 2019, 3:41 PM
Dyolf77_WMF updated the task description. (Show Details)Oct 16 2019, 3:44 PM
Dyolf77_WMF updated the task description. (Show Details)Oct 16 2019, 3:47 PM
Dyolf77_WMF changed Due Date from Oct 10 2019, 11:00 PM to Mon, Oct 28, 11:00 PM.
Dyolf77_WMF updated the task description. (Show Details)Oct 16 2019, 3:50 PM
Dyolf77_WMF updated the task description. (Show Details)
Dyolf77_WMF updated the task description. (Show Details)Oct 16 2019, 3:55 PM
Dyolf77_WMF updated the task description. (Show Details)Oct 16 2019, 3:57 PM
Dyolf77_WMF updated the task description. (Show Details)Oct 16 2019, 4:03 PM
Dyolf77_WMF updated the task description. (Show Details)
Dyolf77_WMF updated the task description. (Show Details)Oct 17 2019, 9:08 PM

Hi @Tgr I updated the list of messages (please see task description), can we make the modifications on WTN? Thanks.

Hi @Tgr I updated the list of messages (please see task description), can we make the modifications on WTN? Thanks.

I would generally recommend creating a new task instead of reopening, for easier tracking.

Tgr moved this task from QA to Incoming on the Growth-Team (Current Sprint) board.Wed, Oct 23, 4:37 PM

Moving to Incoming for prioritization. (The task is reused but this is a new set of messages.)

Btw is it easy to explain to an English speaker when a message will need gender support in Arabic? If so, putting that guidance on some wiki page would be worthwhile.

Dyolf77_WMF updated the task description. (Show Details)Sat, Oct 26, 7:28 AM

@Tgr Thanks,

Btw is it easy to explain to an English speaker when a message will need gender support in Arabic? If so, putting that guidance on some wiki page would be worthwhile.

Sure, I am thinking about it. Will do it! (Just a general rule, every verb in a sentence for persons - singular or plural - has to be with GENDER parameter).

Dyolf77_WMF updated the task description. (Show Details)Sat, Oct 26, 7:58 AM
Dyolf77_WMF updated the task description. (Show Details)Sun, Oct 27, 10:42 AM

@MMiller_WMF can you define the priority of this task (or rather task type, seeing how it will probably be a recurring task)?

Tgr updated the task description. (Show Details)Mon, Oct 28, 1:27 AM
Dyolf77_WMF updated the task description. (Show Details)Mon, Oct 28, 7:47 AM

@Trizek-WMF and @Dyolf77_WMF -- can you each comment on how important this is? It is hard for me to know, since I don't speak a language where this is relevant. Which of these situations do you think is the case:

  1. This must be fixed immediately, because the messages do not make sense to many users.
  2. This should be fixed soon, because many users are getting an experience that may make them want to leave.
  3. This would be nice to fix, but not urgent, because many internet users are used to this problem.

@MMiller_WMF , I think:

  1. This should be fixed soon, because many users are getting an experience that may make them want to leave.
JTannerWMF added a subscriber: JTannerWMF.

With the syntax {{GENDER:|Create}} user page, you should be able to get the current users gender without the parameter. We will try to get this into 1.0 but may not be able to.

Dyolf77_WMF changed the task status from Open to Stalled.Mon, Nov 4, 1:44 PM
Tgr added a comment.Mon, Nov 4, 7:58 PM

To do (besides updating the messages):

  • check if GENDER with no explicit user parameter works in Javascript; if it doesn't make it work (probably less work than trying to pass all through the user parameters)
  • check if GENDER with no explicit user parameter works in ResourceLoader callbacks (where the context user is not available)
Dyolf77_WMF moved this task from Backlog to In progress on the User-Dyolf77 board.Sun, Nov 10, 9:03 AM

I used the syntax {{GENDER:| | }}. On arwiki beta I see the result and it is working in some cases but not in others:


I will wait to investigate more on this.