Page MenuHomePhabricator

[regression- mobile] Homepage - Start model displays broken layout
Closed, ResolvedPublic

Description

The issue is present on testwiki and betalabs.

On iOS 12 (iPhone - a real device) and mobile simulators in SauceLabs (both iPhone and Android) the overlay for the Start module looks as following:

Note: the issue is not present in browser simulators.

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : wmf/1.34.0-wmf.25Homepage: Don't use flexbox for vertical layouts in mobile start module
mediawiki/extensions/GrowthExperiments : masterHomepage: Don't use flexbox for vertical layouts in mobile start module

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 1 2019, 9:21 PM

Change 540959 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Homepage: Don't use flexbox for vertical layouts in mobile start module

https://gerrit.wikimedia.org/r/540959

Catrope claimed this task.Oct 4 2019, 9:18 PM
Catrope edited projects, added Growth-Team (Current Sprint), Mobile; removed Growth-Team.
Catrope moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

Change 540959 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Homepage: Don't use flexbox for vertical layouts in mobile start module

https://gerrit.wikimedia.org/r/540959

Works in betalabs.

Change 541139 had a related patch set uploaded (by Kosta Harlan; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.25] Homepage: Don't use flexbox for vertical layouts in mobile start module

https://gerrit.wikimedia.org/r/541139

Change 541139 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.25] Homepage: Don't use flexbox for vertical layouts in mobile start module

https://gerrit.wikimedia.org/r/541139

Mentioned in SAL (#wikimedia-operations) [2019-10-07T11:35:33Z] <lucaswerkmeister-wmde@deploy1001> Synchronized php-1.34.0-wmf.25/extensions/GrowthExperiments/: SWAT: [[gerrit:541139|Homepage: Don't use flexbox for vertical layouts in mobile start module (T234380)]] (duration: 00m 53s)

Etonkovidova closed this task as Resolved.Oct 7 2019, 7:45 PM

Checked after deployment - all seems to be fine.