Page MenuHomePhabricator

autocomplete in Special:Contributions no longer works
Closed, ResolvedPublic

Description

Reproduce:

  1. https://meta.wikimedia.org/wiki/Special:Contributions
  2. Type "A" into "IP address or username"

Expected:

A list of usernames shown (compare Special:CentralAuth)

Actual:

No autocomplete.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 3 2019, 7:46 AM

Looks like the field has the mw-autocomplete-user class for the mediawiki.userSuggest module but instead should just use HTMLGlobalUserTextField::class as the class instead of the type being text (and drop the dependency on mediawiki.userSuggest).

Wargo added a subscriber: Wargo.Oct 3 2019, 10:12 PM
K6ka added a subscriber: K6ka.Oct 4 2019, 12:57 PM

Change 540969 had a related patch set uploaded (by Jayprakash12345; owner: Jayprakash12345):
[mediawiki/core@master] Fix Autocomplete in Special:Contributions

https://gerrit.wikimedia.org/r/540969

Looks like the field has the mw-autocomplete-user class for the mediawiki.userSuggest module but instead should just use HTMLGlobalUserTextField::class as the class instead of the type being text (and drop the dependency on mediawiki.userSuggest).

I think we should not use HTMLGlobalUserTextField::class as it is a part of CentralAuth Extension. It will create the MediaWiki core dependency to CentralAuth Extension. The simple solution is here is that use type => user. This HTMLForm widget uses mw-autocomplete-user.

Dvorapa added a subscriber: Dvorapa.Oct 7 2019, 5:43 PM
Volker_E triaged this task as High priority.Oct 7 2019, 8:05 PM

Change 540969 merged by jenkins-bot:
[mediawiki/core@master] Special:Contributions: Fix user target autocomplete

https://gerrit.wikimedia.org/r/540969

Volker_E closed this task as Resolved.Oct 7 2019, 8:31 PM
Volker_E assigned this task to Jayprakash12345.
Volker_E removed a project: Patch-For-Review.
Restricted Application added a project: User-Jayprakash12345. · View Herald TranscriptOct 7 2019, 8:31 PM
MarcoAurelio added a comment.EditedOct 8 2019, 6:03 PM

User-notice ? Sort of: "previously, Special:Contributions had an autocomplete functionality that was lost during the transition to the new OOUI design. This functionality has been restored"?

Ammarpad removed a subscriber: Ammarpad.Oct 11 2019, 2:17 PM