Page MenuHomePhabricator

User field in OOUI Special:Contributions is very short
Closed, DuplicatePublic

Description

Right now it is difficult to see an entire ipv6 address in the field. There are also some users with long names. It should probably be much closer to the same width as the namespace selector.

Other discussion about the topic that some script or another may not be loading as expected at the en.wp discussion; search for ipv6 from there.

Event Timeline

Izno created this task.Oct 5 2019, 10:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 5 2019, 10:06 PM
Izno updated the task description. (Show Details)Oct 5 2019, 10:12 PM

The user name field is already of the same width as the namespace selector. Chrome 77.0.3865.90/macOS

Ditto as ammarpad. I am using Chrome Dev 79. I guess it's your browser which renders it like that.

Izno added a comment.EditedOct 6 2019, 2:20 AM

The original reporter was using Chrome.

I have another bug related to these changes: at least on my system (Chrome 77.0.3865.90, Windows 10 v.who-knows) the shortened User: box is not long enough to display a full IPv6 address, which makes it very difficult to use. Can it be restored to its original length? Ivanvector (Talk/Edits) 14:07, 4 October 2019 (UTC)

I'm running around with Firefox 69.0.2 on Windows 10 and experiencing the same issue.

Ammarpad added a comment.EditedOct 6 2019, 3:46 AM

The original reporter was using Chrome.

I have another bug related to these changes: at least on my system (Chrome 77.0.3865.90, Windows 10 v.who-knows) the shortened User: box is not long enough to display a full IPv6 address, which makes it very difficult to use. Can it be restored to its original length? Ivanvector (Talk/Edits) 14:07, 4 October 2019 (UTC)

It was caused by a script in their personal CSS.

I'm running around with Firefox 69.0.2 on Windows 10 and experiencing the same issue.

I cannot reproduce the issue on the same Firefox version (albeit not on Windows). So I believe this was caused by delsort.js script which is in your common.js file.

The script contains

mw.loader.load( "mediawiki.ui.input", "text/css" );

and that's what's causing the issue from the upstream.

Jdforrester-WMF closed this task as Invalid.Oct 7 2019, 5:12 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Sounds like this is a user script issue.

Per Volker's comment at VPT, this was fixed as a result of T234510.