Page MenuHomePhabricator

Broken docker images?
Closed, InvalidPublic

Description

  1. Create the docker image
  2. Follow instructions on copying LocalSettings over and select sqlite as the db
  3. Visit $domain and be presented with Sorry! This site is experiencing technical difficulties.

Try waiting a few minutes and reloading. (Cannot access the database)

Event Timeline

Nwmcsween created this task.Oct 6 2019, 7:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 6 2019, 7:36 PM

Which instruction did you follow? I just realized if it's the dev instructions I forgot to include that composer install needs to be run.

Magol added a subscriber: Magol.Oct 6 2019, 9:49 PM

I added a step on using Composer to download the PHP dependencies (if that is what the problem is): https://www.mediawiki.org/wiki/Docker/Hub#Using_for_MediaWiki_Development

I followed the docker hub install method which is the "Using on a single web server" method, also sort of related mediawiki log errors don't/won't propagate out from the container (even when setting logfile to /dev/stdout) making debugging this really really hard

I followed the docker hub install method which is the "Using on a single web server" method, also sort of related mediawiki log errors don't/won't propagate out from the container (even when setting logfile to /dev/stdout) making debugging this really really hard

You should see the Apache log by doing docker-compose logs -f --tail 100 (though I'm not sure how helpful that would be).

You might also enable error reporting so the errors show up on the page: https://www.mediawiki.org/wiki/Manual:How_to_debug

I'm assuming you ran through the install process and let MediaWiki setup the database?

Aklapper changed the task status from Open to Stalled.Tue, Nov 19, 3:34 PM

@Nwmcsween: Could you please answer the last comment? Thanks :)

It probably was the php composer thing as the docker hub image didn't
explain that. I cannot test it now as I used wiki.js instead.

dbarratt closed this task as Invalid.Tue, Nov 19, 4:08 PM