Page MenuHomePhabricator

Consider what PHP 7.2 point release to use
Closed, ResolvedPublic

Description

https://github.com/symfony/symfony/blob/4.0/composer.json and https://github.com/symfony/symfony/blob/4.4/composer.json have ^7.1.3
https://github.com/symfony/symfony/blob/master/composer.json (to be 5.0 I guess) has ^7.2.9
https://github.com/symfony/symfony/commit/d94d9d792c445240cbaf80c7b413795b71aff718 - I wonder if there's any specific reason to select 7.2.9 as the min supported PHP 7.2, that dates to 16 Aug 2018, well before that commit in May
Something for us to bare in mind when we come to bumping to PHP 7.2
On https://github.com/symfony/symfony/blob/3.4/composer.json#L19 we're good with ^5.5.9|>=7.0.8
But of course, we only require PHP 7.0.0. I suspect most people will have a newer point release... But it does mean our require-dev symfony/yaml will conflict
Filing a separate task
Re-stalling as we have nothing to do until we bump to 7.2 (do we have a task for that to bump this against)

We should query and finalise what version of PHP to support... Currently we have 7.0.0 in composer.json, that's going to be changed...

https://github.com/wikimedia/mediawiki/blob/56e2567/composer.json#L35
https://github.com/wikimedia/mediawiki/blob/ed8e939/includes/PHPVersionCheck.php#L98

Should we consider to use/set 7.2.9 (rather than 7.2.0) to match and not conflict with symfony's requirements?

Ping T216166

Details

Related Gerrit Patches:
mediawiki/core : masterSet minimum PHP version to 7.2.9
mediawiki/core : REL1_34Set minimum PHP version to 7.2.9

Related Objects

StatusSubtypeAssignedTask
ResolvedReedy
ResolvedReedy
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedLegoktm
ResolvedMaxSem
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedDaimona
Resolvedsbassett
ResolvedDaimona
ResolvedDaimona
ResolvedKrinkle
ResolvedJdforrester-WMF

Event Timeline

Reedy created this task.Oct 6 2019, 8:20 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 6 2019, 8:20 PM
Reedy triaged this task as High priority.Oct 6 2019, 8:23 PM

7.2.9 seems fine by me.

Reedy added a comment.Oct 10 2019, 6:49 PM

Debian stable is on 7.3 so that's all good. Old stable is 7.0 so we don't care

Bionic (18.04) has 7.2.19. Xenial has 7.0 so we also don't care

And Wikimedia is on 7.2.22, so we don't care there either

I asked if there was a specific reason why we're using .22 over .0 or whatever and ServiceOps said they aimed for latest&greatest from upstream.

Change 542220 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@master] Set minimum PHP version to 7.2.9

https://gerrit.wikimedia.org/r/542220

Change 542222 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@REL1_34] Set minimum PHP version to 7.2.9

https://gerrit.wikimedia.org/r/542222

Reedy closed this task as Resolved.Oct 10 2019, 8:35 PM
Reedy claimed this task.

Change 542220 merged by jenkins-bot:
[mediawiki/core@master] Set minimum PHP version to 7.2.9

https://gerrit.wikimedia.org/r/542220

Change 542222 merged by jenkins-bot:
[mediawiki/core@REL1_34] Set minimum PHP version to 7.2.9

https://gerrit.wikimedia.org/r/542222