Page MenuHomePhabricator

mw.lua:486 error when asking for function "chunk" at euwiki
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:

You can see it happening here: https://eu.wikipedia.org/w/index.php?title=Lankide:Theklan/Proba_orria&oldid=7070589

Actual Results:

It shows an error when trying to use the function chunk.

Expected Results:

All the code has been copied from eswiki, where it is working perfectly. No other modules seem to be needed, so the error is somewhere else.

Event Timeline

Theklan created this task.Mon, Oct 7, 11:39 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMon, Oct 7, 11:39 AM
Aklapper changed the task status from Open to Stalled.Mon, Oct 7, 11:53 AM

Here, https://eu.wikipedia.org/w/index.php?title=Lankide:Theklan/Proba_orria&oldid=7070589 shows:
Luanda errorea in Modulu:Autoritate_kontrola/berria at line 73:Tried to write global getCommonsValue.
There is nothing about mw.lua:486 error when asking for function "chunk" at euwiki as mentioned in the task summary, hence cannot reproduce.

Aklapper closed this task as Declined.Mon, Oct 7, 11:55 AM

I don't expect a problem in deployed code here but an issue in on-wiki content/code, hence closing this task as invalid for the time being.
However, you can of course still comment on this task and edit it. :)

Aklapper changed the task status from Declined to Invalid.Mon, Oct 7, 11:56 AM

You can track the error if you click there:

Backtrace:

    [C]: in function "error"
    Modulu:No_globals:10: ?
    Modulu:Autoritate_kontrola/berria:73: in function "chunk"
    mw.lua:486: ?
    [C]: ?

Right, but that is only lower down in the stacktrace. The error is Tried to write global... which comes from https://eu.wikipedia.org/wiki/Modulu:No_globals so you'd need to fix or adjust your code if you don't want global declarations.