Page MenuHomePhabricator

Donors seeing only *some* card types on form
Closed, ResolvedPublic

Description

Over the past week, we've seen about 20 donors report not seeing their card type on the form. In the past this has been caused by geolocation errors, and sending them the URL has been enough to get them to see the card they want to use.

I am not sure if this is related to T224929: Not required to choose card type in new Ingenico iframe? but one of the recent donors # 617748 got this Visa-only form when we sent them directly to https://donate.wikimedia.org/wiki/Special:FundraiserLandingPage?uselang=en&country=US

What should we advise donors who do not see the full range of cards? Is this related to the adjustments and tests made in T224929?

Event Timeline

MBeat33 created this task.Oct 8 2019, 4:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 8 2019, 4:14 PM

Oof, looks like an issue in IE11. I'll look into it ASAP.

If they click through on the card link regardless, they should still get all the available options.

Pcoombe closed this task as Resolved.Oct 8 2019, 5:48 PM
Pcoombe claimed this task.

This should be fixed now. Internet Explorer needed the width and height attributes set on the <svg> elements directly, without that they were displaying too wide and pushing the other logos out of view.

I also fixed the vertical alignment of the logos in IE by changing the buttons to line-height: 1;