Page MenuHomePhabricator

"Edit watchlist" missing namespace designations
Closed, ResolvedPublic

Description

Issue

On /wiki/Special:EditWatchlist there used to be sections for each namespace, however it appears these are no longer visible.

This especially important for discussion threads because they do not have a namespace prefix in their displayed item, hence the section heading was the only way of distinguishing a page really called "Foo" vs a discussion thread called "Foo" on a larger page somewhere.

NowBefore

In the above, I thought there was an odd main-space page called "Safari 5.1+". But after clicking it I found myself on [[Talk:Compatibility]], not [[Safari 5.1+]].

Notes

I believe this is a recent regression. From looking at why it is hidden, I guess this might be unexpected fall-out from the decision to hide "redundant" legend headings on Special page forms.

Event Timeline

Krinkle created this task.Oct 9 2019, 10:21 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 9 2019, 10:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Interesting that some wikis - testwiki, cawiki, but not mediawiki and enwiki - would have a table of content with entries for namesapces, e.g.

Izno added a subscriber: Izno.Oct 15 2019, 4:07 PM

I see a TOC for enwiki with links that work but no headers, in multiple skins. The source also does not have the headers.

This bug is caused by the code added here: https://gerrit.wikimedia.org/r/c/mediawiki/core/+/281100/66/resources/src/mediawiki.special/contributions.less

Counterintuitively, that style file is apparently loaded on all special pages (or at least many of them, including Special:EditWatchlist), rather than just Special:Contributions. The rule on line 24 meant to hide a redundant header on Special:Contributions (identical to the page title) ends up hiding all of the headers on Special:EditWatchlist too.

matmarex claimed this task.Oct 16 2019, 8:27 PM

Change 543691 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] Don't apply styling for Special:Contributions on other pages

https://gerrit.wikimedia.org/r/543691

Change 543691 merged by jenkins-bot:
[mediawiki/core@master] Don't apply styling for Special:Contributions on other pages

https://gerrit.wikimedia.org/r/543691

Change 543700 had a related patch set uploaded (by Krinkle; owner: Bartosz Dziewoński):
[mediawiki/core@wmf/1.35.0-wmf.2] Don't apply styling for Special:Contributions on other pages

https://gerrit.wikimedia.org/r/543700

Change 543710 had a related patch set uploaded (by Jforrester; owner: Bartosz Dziewoński):
[mediawiki/core@REL1_34] Don't apply styling for Special:Contributions on other pages

https://gerrit.wikimedia.org/r/543710

Change 543710 merged by jenkins-bot:
[mediawiki/core@REL1_34] Don't apply styling for Special:Contributions on other pages

https://gerrit.wikimedia.org/r/543710

Change 543700 merged by jenkins-bot:
[mediawiki/core@wmf/1.35.0-wmf.2] Don't apply styling for Special:Contributions on other pages

https://gerrit.wikimedia.org/r/543700

Mentioned in SAL (#wikimedia-operations) [2019-10-16T22:30:41Z] <jforrester@deploy1001> Synchronized php-1.35.0-wmf.2/resources/src/mediawiki.special/contributions.less: T235137 Don't apply styling for Special:Contributions on other pages (duration: 00m 59s)

Change 543722 had a related patch set uploaded (by Jforrester; owner: Bartosz Dziewoński):
[mediawiki/core@wmf/1.35.0-wmf.1] Don't apply styling for Special:Contributions on other pages

https://gerrit.wikimedia.org/r/543722

Change 543722 merged by jenkins-bot:
[mediawiki/core@wmf/1.35.0-wmf.1] Don't apply styling for Special:Contributions on other pages

https://gerrit.wikimedia.org/r/543722

Mentioned in SAL (#wikimedia-operations) [2019-10-16T23:00:24Z] <jforrester@deploy1001> Synchronized php-1.35.0-wmf.1/resources/src/mediawiki.special/contributions.less: T235137 Don't apply styling for Special:Contributions on other pages (duration: 00m 59s)

Jdforrester-WMF closed this task as Resolved.Oct 16 2019, 11:01 PM
Jdforrester-WMF edited projects, added UI-Standardization; removed Patch-For-Review, OOUI.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Deployed.