This has emerged while upgrading PHPCS to the latest version for all repos (and hence, starting to use PHP72+ features). Currently, many extensions have an explicit PHP version requirement in composer.json.
Aside from special cases (i.e. extensions which already required PHP7+), several extensions require PHP 5.6.99+, which was the "correct" value as long as we supported HHVM.
Others have different requirements, varying from 5.0.0 (!) to 5.5.9. For some of them, it's safe to assume that the intention was to require the same version as MW core, but they fell out of date.
However, others are actually (claimed to be) compatible with PHP5. For instance, some extensions with "master" compatibility.
The goal of this task is to understand whether, and under what premises, an extension may set an explicit PHP requirement in its composer.json. And ideally, what PHP versions are admissible, too.
Personally, I think it doesn't make any sense to try to support a PHP version < than the version supported by the oldest supported release of MW.
For instance, since right now MW 1.31 is the oldest supported version and it only supports HHVM or PHP7+, *every* extension should do the same (i.e. the composer requirement should be 5.6.99+). IMHO this is a no-brainer.
I (@Daimona) think that extensions should *not* have an explicit PHP version requirement, unless it's (meant to be) different from the one in core.