Page MenuHomePhabricator

Special:AbuseFilter/test cannot be used on autocreateaccount
Closed, DeclinedPublic

Description

To reproduce:

  1. Go to a certain active wiki with accounts recently automatically created (I've tested on zhwiki)
  2. Visit [[Special:Abusefilter/test]] and use the expression action == 'autocreateaccount' to test
  3. No result appears. To compare, action == 'createaccount' works fine if there are accounts created on that wiki shortly before testing.

Event Timeline

Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptOct 14 2019, 2:44 PM
Daimona renamed this task from Abuse filter cannot match autocreateaccount to Special:AbuseFilter/test cannot be used on autocreateaccount.Oct 14 2019, 2:45 PM
Xiplus added a subscriber: Xiplus.Oct 14 2019, 2:46 PM
Daimona changed the task status from Open to Stalled.Oct 14 2019, 2:53 PM
Daimona added a subscriber: Daimona.

That's because automatic account creations are not in the recent changes. Hence, the AF cannot pick them. This lack is intentional (they would clog the logs), so I don't see any solution here.

Daimona moved this task from Backlog to Testing filters on the AbuseFilter board.Nov 20 2019, 10:41 AM

That's because automatic account creations are not in the recent changes. Hence, the AF cannot pick them. This lack is intentional (they would clog the logs), so I don't see any solution here.

@Daimona: Does that mean this task should be declined, as per https://www.mediawiki.org/wiki/Bug_management/Bug_report_life_cycle ?

Daimona closed this task as Declined.Thu, Nov 5, 12:28 PM

That's because automatic account creations are not in the recent changes. Hence, the AF cannot pick them. This lack is intentional (they would clog the logs), so I don't see any solution here.

@Daimona: Does that mean this task should be declined, as per https://www.mediawiki.org/wiki/Bug_management/Bug_report_life_cycle ?

The answer depends on whether a task (or intention) exists to put autocreations in the recent changes (aka a task against MediaWiki-Recent-changes). If so, that task should be a subtask of this one, or we might even close this task as a duplicate of that one. If that bug existed but was declined, or the intention is *not* to add these entries to RC, then this task can be declined as well. In both cases, declining this task seems a valid compromise. That is, unless someone comes up with a way of circumventing this issue without the need for a core change, in which case they can reopen this task :-)