Page MenuHomePhabricator

Unable to log into ban.wiki
Closed, ResolvedPublicBUG REPORT

Description

I cannot log into ban.wiki (just created, see T234768: Create Balinese Wikipedia)

The warning is that "Kata sandi yang Anda masukkan salah. Silakan coba lagi." - per google translate, the password is incorrect.
But, it isn't; the same password works for logging into metawiki with the same account

Event Timeline

Restricted Application added a project: User-DannyS712. · View Herald TranscriptOct 14 2019, 5:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Cannot reproduce. Are you really sure you use the correct password?

What misleads me is the following sequence in logs:

	2019-10-14T17:09:06	mw1266	INFO	Already fully migrated user 'DannyS712'
	2019-10-14T17:09:06	mw1266	INFO	authentication for 'DannyS712' succeeded
	2019-10-14T17:08:31	mw1250	INFO	Login failed for elevated DannyS712 from (redacted) - (redacted) - (redacted) Incorrect username or password entered.
Please try again.
	2019-10-14T17:08:29	mw1250	INFO	Already fully migrated user 'DannyS712'
	2019-10-14T17:08:29	mw1250	INFO	authentication for 'DannyS712' succeeded
	2019-10-14T17:05:29	mw1262	INFO	Login failed for elevated DannyS712 from (redacted) - (redacted) - (redacted) Incorrect username or password entered.
Please try again.
	2019-10-14T17:05:28	mw1262	INFO	Already fully migrated user 'DannyS712'
	2019-10-14T17:05:28	mw1262	INFO	authentication for 'DannyS712' succeeded

Why does it say authentication for 'DannyS712' succeeded?

Yes, it is the correct password.
I tried to replicate it with DannyS712 test, but it logged in just fine.
With DannyS712, I still get "Kata sandi yang Anda masukkan salah. Silakan coba lagi." or "Incorrect username or password entered. Please try again."

@DannyS712 was it necessary to login again using your credentials? I mean I logged in on meta-wiki and then navigated to ban-wikipedia. It automatically created a local account and logged me in.

DannyS712 added a comment.EditedOct 14 2019, 7:38 PM

@DannyS712 was it necessary to login again using your credentials? I mean I logged in on meta-wiki and then navigated to ban-wikipedia. It automatically created a local account and logged me in.

I thought it would automatically log me in, but it didn't; that's why I tagged MediaWiki-extensions-CentralAuth

Masumrezarock100 changed the subtype of this task from "Task" to "Bug Report".Oct 14 2019, 7:56 PM

Oh, I see. I just hope it is not related to T233489.

Can't reproduce.

Masumrezarock100 added a comment.EditedOct 14 2019, 10:02 PM

@DannyS712 I see that you already have an account on ban-wikipedia. Are you still facing this problem? If so, could you clear your cookies and try again?

@DannyS712 I see that you already have an account on ban-wikipedia. Are you still facing this problem? If so, could you clear your cookies and try again?

Yes, still am. I use chrome:

  • Try to login normally -> "There seems to be a problem with your login session; this action has been canceled as a precaution against session hijacking. Please resubmit the form."
  • Try to login with incognito mode -> "Incorrect username or password entered. Please try again."

How are you seeing that I have an account there?

@DannyS712 I see that you already have an account on ban-wikipedia. Are you still facing this problem? If so, could you clear your cookies and try again?

Yes, still am. I use chrome:

  • Try to login normally -> "There seems to be a problem with your login session; this action has been canceled as a precaution against session hijacking. Please resubmit the form."
  • Try to login with incognito mode -> "Incorrect username or password entered. Please try again."

How are you seeing that I have an account there?

Because your userpage on ban-wikipedia doesn't state "This username is not registered." And you'll see the date of your registration beneath your username on the mobile version. But your CA states otherwise. This is likely a CentralAuth issue. Guess the bug in T233489 hasn't properly been fixed.

Reedy added a subscriber: Reedy.Oct 14 2019, 11:17 PM

@DannyS712 I see that you already have an account on ban-wikipedia. Are you still facing this problem? If so, could you clear your cookies and try again?

Yes, still am. I use chrome:

  • Try to login normally -> "There seems to be a problem with your login session; this action has been canceled as a precaution against session hijacking. Please resubmit the form."
  • Try to login with incognito mode -> "Incorrect username or password entered. Please try again."

How are you seeing that I have an account there?

Because your userpage on ban-wikipedia doesn't state "This username is not registered." And you'll see the date of your registration beneath your username on the mobile version. But your CA states otherwise. This is likely a CentralAuth issue. Guess the bug in T233489 hasn't properly been fixed.

Why do you keep referencing that bug? That bug was related to a memcached issue on beta. This isn't beta

DannyS712 added a comment.EditedOct 14 2019, 11:18 PM

It also doesn't show my meta page - I guess that a local account must exist, that is not attached to my SUL account (or recognized as unattached), and that has a different password

That being said, I have since discovered that I appear to have made edits to the wiki - https://ban.wikipedia.org/wiki/Kusus:Kontribusi_pengguna/DannyS712 shows 2 edits made to https://ban.wikipedia.org/w/index.php?title=Kategori:Peserta_WikiLatih_Basa_Bali_di_Denpasar_tanggal_29_September_2019&action=history. Looking at the logs (https://ban.wikipedia.org/w/index.php?title=Kusus:Catatan&page=Kategori%3APeserta+WikiLatih+Basa+Bali+di+Denpasar+tanggal+29+September+2019), the page was imported by file upload. Since there is no interwiki prefix before editors' names in the history, my guess is that edits were assigned to local users, and, since I didn't have a local account at the time, one was created? @jhsoby performed the import - any ideas?

This reminds me (a bit) of T223036: Detached local SUL account User:Carmen0428 needs to be reunited with the global account - is https://wikitech.wikimedia.org/wiki/Reattach_a_global_account at all helpful? As far as I can see, there is a local account that isn't attached to my global account.

@DannyS712 have you tried to reset your password there?

DannyS712 added a comment.EditedOct 14 2019, 11:39 PM

@DannyS712 have you tried to reset your password there?

Yes, but after submitting with the temporary password, setting a new one failed with "Kredensial yang diberikan tidak dapat diganti, karena tidak ada yang akan menggunakannya." and I was kicked back out

The english equivalent of the message is "The supplied credentials cannot be changed, as nothing would use them." - returned by AuthManager::allowsAuthenticationDataChange

@DannyS712 Did you already try make new account with different name in same computer? Thanks for this report. I will let you know if any person in our local community get same problem.

@jhsoby I also have problem here that all Category pages not working in ban.wiki.

@DannyS712 Did you already try make new account with different name in same computer? Thanks for this report. I will let you know if any person in our local community get same problem.

I was able to login with DannyS712 test, so the problem isn't with the computer. I think its just with the account already having edits

Maybe a steward can delete that local account and/or unify it with your global account.

Maybe a steward can delete that local account and/or unify it with your global account.

We cannot delete local accounts nor force the unification of any account, sorry.

I'll look into this.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptOct 18 2019, 11:59 AM

Mentioned in SAL (#wikimedia-operations) [2019-10-18T15:06:54Z] <Urbanecm> Reattach DannyS712@banwiki to DannyS712@SUL (T235446)

Urbanecm closed this task as Resolved.Oct 18 2019, 3:09 PM

I've reviewed the user_email for your account at banwiki and SUL, it matches, so I've unified the account. You should now be able to login. It's probably worth investigating. Created T235885 for that. Tentatively resolving, feel free to reopen if this didn't work!

DannyS712 reopened this task as Open.Oct 18 2019, 3:13 PM

@Urbanecm nope - "Incorrect username or password entered. Please try again." and then "There seems to be a problem with your login session; this action has been canceled as a precaution against session hijacking. Please resubmit the form." - still won't work

Mentioned in SAL (#wikimedia-operations) [2019-10-18T15:38:24Z] <Urbanecm> Rename DannyS712@banwiki to DannyS712 (T235446) locally (T235446)

Mentioned in SAL (#wikimedia-operations) [2019-10-18T15:38:24Z] <Urbanecm> Rename DannyS712@banwiki to DannyS712 (T235446) locally (T235446)

Mentioned in SAL (#wikimedia-operations) [2019-10-18T15:38:44Z] <Urbanecm> Run extensions/CentralAuth/maintenance/createLocalAccount.php --wiki=banwiki DannyS712 (T235446)

Mentioned in SAL (#wikimedia-operations) [2019-10-18T15:40:15Z] <Urbanecm> Reassign edits from DannyS712 (T235446) to DannyS712 at banwiki (T235446)

Mentioned in SAL (#wikimedia-operations) [2019-10-18T15:40:15Z] <Urbanecm> Reassign edits from DannyS712 (T235446) to DannyS712 at banwiki (T235446)

@DannyS712 What about now? I've renamed the account locally, and reassigned your edits.

DannyS712 closed this task as Resolved.EditedOct 18 2019, 4:45 PM

@DannyS712 What about now? I've renamed the account locally, and reassigned your edits.

It works now.

Is there anything to do with https://ban.wikipedia.org/wiki/User:DannyS712_(T235446) other than ignore it?