Page MenuHomePhabricator

Newcomer tasks: suppress editor popups for guidance
Closed, ResolvedPublic

Description

Part of the Growth team's "newcomer tasks" project includes guiding newcomers to complete suggested edits once they are in the editor. We plan to use the help panel feature to do this, and to have the help panel open for newcomers when they first click edit after arriving from the suggested edits module. At that first moment, we don't want any other popups to appear, as that would make it unclear as to where the newcomer is supposed to pay attention -- we want all their onboarding to happen in the help panel.

Therefore, the Growth team needs the ability to suppress popups that come from the editor for specific users that arrive on articles via the suggested edits module.

We know that some popups are caused by the editor itself, and some come from notifications or other sources -- but we're not sure which ones. The work in T229887: Audit notifications received by new users upon opening the editor taught us some more about this. It now sounds like it is possible to build a hook to suppress popups that come from the Visual Editor, but not to automatically suppress every type of popup at the moment of arriving and initiating the editor. What we want to do is build the hook for suppressing Visual Editor popups, and then see what other popups still appear in our target wikis. We'll deal with those separately.

Note that this suppression also includes the pulsing blue dots that appear on the "Add link" and "Add citation" buttons in the VE toolbar.

This work is needed in order for the Growth team to release Newcomer Tasks 1.2, which is planned for March.

Event Timeline

MMiller_WMF updated the task description. (Show Details)Feb 7 2020, 5:57 PM
MMiller_WMF updated the task description. (Show Details)Feb 28 2020, 11:34 PM

The welcome dialog can be suppressed temporarily with the vehidebetadialog query string parameter. Adding a similar param for user education indicators (blue dots) would be fairly trivial.

You can also set the user options visualeditor-hidebetawelcome and visualeditor-hideusered via simple API calls if you want to suppress these permanently.

Either approach should be simple enough for the Growth team to implement, but let us know if you need more guidance.

@marcella -- is this task on our team now to complete?

MMiller_WMF renamed this task from Growth team needs to be able to suppress editor popups to Newcomer tasks: suppress editor popups for guidance.Mar 10 2020, 10:59 PM
MMiller_WMF removed marcella as the assignee of this task.Apr 6 2020, 5:11 AM

I think your team has a better idea of where the code needs to go as it will be within your team's extension. If you find you do need to make changes to VE, we can help with that.

I've submitted patches for all three of the subtasks in VE. Once those are merged, the guidance feature should be able to suppress all VE popups by sending the user to a URL like /wiki/Egg_tart?vehidebetadialog=1&vehidenotices=1&vehideusered=1. For convenience, we could also consider adding a single URL parameter that does all three of those things.

For convenience, we could also consider adding a single URL parameter that does all three of those things.

Sounds good to me.

This comment was removed by Catrope.

@matmarex objects to suppressing the edit notice popup at T249971#6050425 . I think it's probably fine to not suppress this, since most articles don't have these (anonymous users always get one, but guidance users are never anonymous), and since it's not a modal popup but a popup coming out of the toolbar. @MMiller_WMF what do you think?

@Catrope @matmarex -- thanks for checking. What are some examples of edit notices? I know that the ones for anonymous users get the one telling them to create an account, but what are the ones that registered users could get?

Change 589462 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Suggested edits: Suppress VE dialogs for suggested edit page views

https://gerrit.wikimedia.org/r/589462

Catrope moved this task from In Progress to Code Review on the Growth-Team (Current Sprint) board.

I'm an idiot, this was actually very simple, and I didn't need the refactoring that I was doing in VE at all. We don't need new URL parameters either.

I'll still finish the refactoring in VE because the way that hiding the welcome dialog is handled could be much simpler and much easier to understand, and I'm already halfway done with it anyway.

@Catrope @matmarex -- thanks for checking. What are some examples of edit notices? I know that the ones for anonymous users get the one telling them to create an account, but what are the ones that registered users could get?

For ones coming from the software, see the list here (sub-bullets of the second top-level bullet point): T229887#5819921. The only ones that I think our users could encounter are the ones about them being blocked or the wiki being in read-only mode; in each of those cases, they won't be able to save their edit, so it makes sense to warn them. (And also, they hopefully shouldn't have been presented with an edit button in the first place, unless they were blocked or the wiki went read-only in between them loading the page and clicking edit.)

Communities can also add edit notices to individual pages. Our target wikis don't seem to use this feature much. Czech Wikipedia doesn't have per-page edit notices at all, Korean has them but doesn't currently have any in the main namespace and Vietnamese and Arabic each have a small number. Here's an example of a custom edit notice that you will see if you edit this article about the Vietnam war. I don't think we have to worry about these much, because few articles on our target wikis have them (and it appears that many articles that do have them are protected, so we wouldn't suggest them anyway), and when they do appear they generally contain useful information like "be careful editing this article, it's controversial" or "don't try to 'fix' this person's birthday". If we were talking about English Wikipedia I would feel differently, because they have thousands upon thousands of page-specific edit notices and use them for such trivial things as "please write in British English on this page" or "please use this date format", but on our target wikis this doesn't seem to be an issue.

...such trivial things as "please write in British English...

Shhh, @Jdforrester-WMF might hear you!

@Catrope -- okay, I understand now about the edit notices. We can refrain from suppressing them, and when @Etonkovidova does QA with new accounts, we can see if any come up that we weren't expecting, and see if they inhibit the experience.

Change 589736 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: Add mw.libs.ve.disableWelcomeDialog()

https://gerrit.wikimedia.org/r/589736

Change 591419 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Suggested edits: Use the new, nicer way to disable VE's welcome dialog

https://gerrit.wikimedia.org/r/591419

Change 589736 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: Add mw.libs.ve.disableWelcomeDialog()

https://gerrit.wikimedia.org/r/589736

Change 591419 abandoned by Catrope:
Suggested edits: Use the new, nicer way to disable VE's welcome dialog

Reason:
Squashed into https://gerrit.wikimedia.org/r/c/mediawiki/extensions/GrowthExperiments/ /589462

https://gerrit.wikimedia.org/r/591419

Change 593875 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/VisualEditor@master] init: Manage education popup state the same way as welcome popup state

https://gerrit.wikimedia.org/r/593875

Change 593876 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Homepage: Use the new, nicer way to disable VE's education popups

https://gerrit.wikimedia.org/r/593876

Change 593875 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] init: Manage education popup state the same way as welcome popup state

https://gerrit.wikimedia.org/r/593875

Change 589462 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Suggested edits: Suppress VE dialogs for suggested edit page views

https://gerrit.wikimedia.org/r/589462

Change 593876 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Homepage: Use the new, nicer way to disable VE's education popups

https://gerrit.wikimedia.org/r/593876

Checked in betalabs target wiki

  • the blue dots for Cite and Link won't be present when a user starts editing a Suggested edit article
  • it seems that there are no other VE related popups/notifications interfering with the Guidance panel

Note: the comment https://phabricator.wikimedia.org/T229887 makes sense though - VE has its own guidance which might be helpful for newcomers - it provides direct clues to valuable edit options - Link and Cite - ib the Guidance tips such info is buried in the text:

The purpose of edit notices is to be read before one edits the article. I think hiding them, especially for newcomers, would be against the wishes of the established editors.

I created a separate task - T254943: GrowthExperiments features popups issues - for two additional cases with popups interference.

I'll do the review on this one.

MMiller_WMF closed this task as Resolved.Fri, Jun 12, 1:05 AM

This looks like it is working as expected in production.