Page MenuHomePhabricator

[BUG] Images reviewed in the Popular tab still present in Personal uploads
Closed, ResolvedPublicBUG REPORT

Description

When reviewing the suggestions in the "Popular" tab and then moving to the "Personal Uploads" tab, you can see that the reviewed images are still present in the queue and the page need to be refreshed.

Steps to Reproduce:

  • Upload an image
  • Review suggestions in the "Popular" tab of the uploaded image
  • Switch to the "Personal uploads" tab without refreshing the page

Actual Results:

The reviewed images are still present in the queue

Expected Results:

The reviewed images aren't present in the queue

Details

Related Gerrit Patches:
mediawiki/extensions/MachineVision : masterMove query to top-level component

Event Timeline

MSantos created this task.Oct 16 2019, 7:46 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 16 2019, 7:46 PM
MSantos updated the task description. (Show Details)Oct 16 2019, 7:47 PM
Restricted Application added a project: Structured-Data-Backlog. · View Herald TranscriptOct 16 2019, 7:48 PM
Mholloway triaged this task as Medium priority.Oct 16 2019, 7:48 PM

Thanks for pointing this out. I think we're going to need to do a new query on every tab change, plus ensure that only one query is happening at any given time. Because of this and the difficulty of keeping the "Image X of Y for review" heading up to date, I think it makes sense to move all query logic into the top-level component (SuggestedTagsPage) so we're only ever running one query at a time and it's easy to determine the current number of results. I'm working on refactoring that component and SuggestedTagsCardstack today.

AnneT claimed this task.Oct 17 2019, 12:54 PM

Change 543932 had a related patch set uploaded (by Anne Tomasevich; owner: Anne Tomasevich):
[mediawiki/extensions/MachineVision@master] Move query to top-level component

https://gerrit.wikimedia.org/r/543932

Change 543932 merged by jenkins-bot:
[mediawiki/extensions/MachineVision@master] Move query to top-level component

https://gerrit.wikimedia.org/r/543932

AnneT moved this task from In development to Done on the Machine vision board.Oct 22 2019, 6:27 PM
Ramsey-WMF closed this task as Resolved.Dec 16 2019, 10:41 PM
Ramsey-WMF added a subscriber: Ramsey-WMF.

Can't reproduce this so considering it done.