Page MenuHomePhabricator

๐Ÿ› Bug | Change payment date according to the payment notification
Closed, ResolvedPublic5 Estimate Story Points

Description

Current situation: once a user submits data for a PPL or MCP donation, we store this data as an incomplete donations and set a time stamp. Regardless of the actual payment date according to the payment provider we set this incomplete data set incl. its early time stamp to a complete data set. This leads to a deviation of the time that we export to VEWA and the time the user actually completed the donation on the external payment site (in some cases). The latter is used by our accounting.

So the problem is that the donations might be booked on the wrong day if the donation happens near the change of a day or even year. The "right" date is the one of the confirmation of the payment.

Two examples

Beispiel PayPal/
Spenden-ID: 3254517

Backend:
Zeitstempel: 2019-08-31 23:59:01

PayPal
Spende erhalten: 1. September 2019 um 00:02:33 MESZ
(Transaktionscode: 0WP61548C2588384G)

VEWA
Sollgestellt und gebucht am 31.08.2019


Beispiel MCP/
Spenden-ID: 3262086

Backend
Zeistempel: 2019-09-15 23:59:41

MCP
Datum 16.09.2019 - 00:01:24
(Transaktionsnnummer: spenden.wikimedia.de-ID7m5g17sd92)

VEWA
Sollgestellt und gebucht am 15.09.2019

Expected behavior: the complete donation data set gets the time stamp that the payment provider tells us, so we export the correct time of the donation to VEWA and are able to send out correct donation receipt.

Note: Due to our current database structure and not wanting to do database changes and major refactorings during the campaign, we implement this on the export side of this and track the required changes to FundraisingFrontend in T238920

Event Timeline

Restricted Application added a project: WMDE-FUN-Team. ยท View Herald TranscriptOct 17 2019, 11:24 AM
Restricted Application added a subscriber: Aklapper. ยท View Herald Transcript
tmletzko updated the task description. (Show Details)Oct 17 2019, 11:24 AM
Jan_Dittrich updated the task description. (Show Details)Oct 21 2019, 9:21 AM
Jan_Dittrich set the point value for this task to 5.
chrp renamed this task from Change payment date according to the payment notification to ๐Ÿ’ฐ spenden.wikimedia.de | Change payment date according to the payment notification.Nov 8 2019, 7:26 PM
chrp moved this task from Heap to Incubation on the WMDE-FUN-Funban-2019 board.
chrp renamed this task from ๐Ÿ’ฐ spenden.wikimedia.de | Change payment date according to the payment notification to ๐Ÿ› Bug | Change payment date according to the payment notification.Nov 11 2019, 2:20 PM
chrp moved this task from Incubation to Heap on the WMDE-FUN-Funban-2019 board.
gabriel-wmde moved this task from Heap to Doing on the WMDE-FUN-Funban-2019 board.
chrp removed gabriel-wmde as the assignee of this task.Nov 18 2019, 10:46 AM
chrp moved this task from Doing to Heap on the WMDE-FUN-Funban-2019 board.
chrp added a subscriber: gabriel-wmde.
chrp added a subscriber: chrp.

Please talk to Garbiel when continuing this ticket

gabriel-wmde updated the task description. (Show Details)
kai.nissen closed this task as Resolved.Thu, Jan 9, 5:47 PM
kai.nissen claimed this task.