Page MenuHomePhabricator

Make Getting Started temporarily suppress the VE dialog by adding "vehidebetadialog" to the query string
Open, Needs TriagePublic

Description

Make Getting Started temporarily suppress the VE dialog by adding "vehidebetadialog" to the query string. The user will still see it the next time they use the editor, so they won't be missing out on any info.

When a user creates a new account, Getting Started prompts them with the suggestion to edit the current page with additional guidance.

If the user clicks on "Edit source" (the editing option provided) the user gets directed to the Visual Editor in visual mode. There, the Getting Started dialogs appear on top of the Visual Editor introduction one.

This is a short-term solution that will improve the experience of new users. For more discussion about other solution options and longer-term needs, please see the parent ticket T189569.

Event Timeline

marcella created this task.Oct 18 2019, 2:29 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 18 2019, 2:29 AM

From the task description...

The user will still see it [the VE dialog] the next time they use the editor, so they won't be missing out on any info.

Thanks for moving this along @marcella, @kaldari and @kostajh. Does the below accurately describe what the experience will be like for contributors once this patch is merged?

"First" VE editing session: contributor will see the Getting Started prompts (e.g. "Preview your changes (optional)"; contributors will NOT see the "Switch to the source editor / Start editing" dialog
"Second" VE editing session: contributors will see the "Switch to the source editor / Start editing" dialog; contributors will NOT see the Getting Started prompts (e.g. "Preview your changes (optional)")

kostajh removed kostajh as the assignee of this task.Oct 22 2019, 6:55 AM
kostajh moved this task from In Progress to Needs PM Review on the Growth-Team (Current Sprint) board.
kostajh added subscribers: phuedx, kostajh.

@phuedx has proposed that we put this on hold, so I'm moving this out of "In progress" until I hear further.

JTannerWMF added a subscriber: JTannerWMF.

The Growth Team evaluated this in Board Refinement and we were told this is on hold, so we need further guidance as to why this is on hold? @marcella @phuedx

JTannerWMF moved this task from Inbox to Blocked on the Growth-Team board.Oct 29 2019, 2:11 PM

@phuedx could you clarify what your concerns about this approach are?

@phuedx could you clarify what your concerns about this approach are?

Thanks for the pings, both. My initial suggestion was that GettingStarted should be sunset and therefore this stopgap measure should be unnecessary. I appreciate @MMiller_WMF's point that sunsetting things quickly without time for consultation could be disruptive. With that in mind, I don't think this should be on hold.

I wrote a fair chunk of GettingStarted so if you need code review within the GettingStarted extension, then LMK.

@JTannerWMF - Per @phuedx's comment above, we should move forward on this task.

Thanks for moving this along @marcella, @kaldari and @kostajh. Does the below accurately describe what the experience will be like for contributors once this patch is merged?

@ppelberg - Basically, yes, although whether you initially get the Visual Editor or the Wikitext Editor depends on what Wiki you are on. Regardless, you get conflicting dialog boxes either way and the solution is still the same.

@ppelberg @marcella - This task was unblocked in October 2019, but is still sitting in the Blocked column. Can we either move this forward or decline it?

kaldari removed a subscriber: JTannerWMF.Jun 3 2020, 6:23 PM
kaldari moved this task from Blocked to Upcoming Work on the Growth-Team board.Jun 5 2020, 9:30 PM

Boldly moving to "Upcoming Work" so it isn't forgotten about. Feel free to move elsewhere if appropriate.

ppelberg added a comment.EditedJun 9 2020, 8:14 PM

Boldly moving to "Upcoming Work" so it isn't forgotten about. Feel free to move elsewhere if appropriate.

We'll put this task in the appropriate place this week. Thank you for bumping, @kaldari.

EDIT: Editing does not see any reason for work on this to be blocked. Striking through the comment I originally posted as I misunderstood @kaldari as suggesting Editing take on this work.

@marcella @MMiller_WMF - I really don't want to micro-manage here, but we've been kicking this bug around for 2 and a half years now. Any chance we could slide it in some time soon? It creates a poor experience for every new editor on our projects :(

@phuedx - Since I can't get any traction with the Growth team on this, any chance you'd like to own it?

Follow up to a conversation @MMiller_WMF and I had in chat
As a short-term fix, doing what I understand this task to be proposing [i] sounds good to me.


i. Making it so in the moment shown below, the only dialog people will see is the one titled You're almost done!:

Aside: writing T235812#6468930 reminded of the need to investigate the helpfulness of the current GettingStarted "program." I created T263089 to explore this, assuming T229887 is where the higher order question of what are the ranges of experiences people encountering the editing interfaces for the first time can have is being explored.

The Growth team will plan to do this work at the beginning of Q2, so we're going to pull this on to our board now. Thanks for the continued advocacy to make sure our new users have the best possible experience.

@phuedx - Since I can't get any traction with the Growth team on this, any chance you'd like to own it?

Sorry for not responding sooner, @kaldari. I've been OoO.

The Growth team will plan to do this work at the beginning of Q2, so we're going to pull this on to our board now. Thanks for the continued advocacy to make sure our new users have the best possible experience.

Rad. LMK if you need additional review.

Tgr claimed this task.Oct 15 2020, 2:01 AM

Change 634187 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GettingStarted@master] Suppress VisualEditor welcome dialog when tour is active

https://gerrit.wikimedia.org/r/634187

Tgr added a comment.Oct 15 2020, 11:12 PM

Testing instructions:

  • enable VisualEditor dialog by running new mw.Api().saveOption( 'visualeditor-hidebetawelcome', 0 ) in the JS console
  • trigger the GettingStarted dialog by adding gettingStartedReturn=1 to the URL query string

Change 634187 merged by jenkins-bot:
[mediawiki/extensions/GettingStarted@master] Suppress VisualEditor welcome dialog when tour is active

https://gerrit.wikimedia.org/r/634187

Etonkovidova added a subscriber: Etonkovidova.EditedFri, Nov 20, 1:38 AM

(edited) Testing by creating real accounts (vs running the Console snippet) did not show that Getting started interfers with VE dialog.

The screenshot below is either a very edge case (not reproducible) or just a result of using the testing steps from the comment above,

Opening VE will display correctly suppressed VE dialog - https://ca.wikipedia.beta.wmflabs.org/w/index.php?title=Pomezia&action=edit&vehidebetadialog=1. But if switching to wikitext editor (not making any edits in VE), then the both popups would be displayed:

Etonkovidova closed this task as Resolved.Fri, Nov 20, 7:13 PM
Tgr added a comment.Fri, Nov 20, 11:21 PM

Opening VE will display correctly suppressed VE dialog - https://ca.wikipedia.beta.wmflabs.org/w/index.php?title=Pomezia&action=edit&vehidebetadialog=1. But if switching to wikitext editor (not making any edits in VE), then the both popups would be displayed:

Doesn't the task need more work, then?

This could either be fixed in GettingStarted (by detecting there is an ongoing tour and adding vehidebetadialog to the editor switch URL - does the parameter work in the source editor?) or in VE (by remembering vehidebetadialog / suppressVePopup() during editor switches). The second seems like the better approach to me, as I think that's how that swotch should behave regardless of who triggered it, but I don't know if the Editing team agrees or whether it is easy to do.

MMiller_WMF reopened this task as Open.Mon, Nov 23, 6:23 PM

Here's what we want to do: once this change is in enwiki, @Etonkovidova can create new accounts there to test it, and that will give us a clear understanding of what does and does not work right, and if there are issues, we will bring this task back to fix them.

Tentatively moving the task to Needs More Work.

Here's what we want to do: once this change is in enwiki, @Etonkovidova can create new accounts there to test it, and that will give us a clear understanding of what does and does not work right, and if there are issues, we will bring this task back to fix them.

Checked in enwiki wmf.18 - confirmed the issue mentioned in my comment above. The screenshot below is from the enwiki wmf.18:


Things to consider

  • the interference happens only when a user switches to Source editing during a specific step during GettingStarted tour
  • the Editor options popup appears only once - even if a user doesn't interact with it - the editors display options (the editor tab) will default to the last used editor.

Steps to reproduce:

  1. Create a new account on enwiki
  2. The Getting started tour will be present

  1. Click on "Edit a suggested article" in the popup - the article loads with VE as the only editor option but without VE dialog asking for editor preference - Correct behavior.
  2. Click on "Show me more", so the more popups will be present

  1. If 'Edit' will be clicked - the editor preference dialog won't be shown - Correct behavior.

  1. Switch to Edit source via the pencil button drop-down menu option "Source editing" - then the Editor preference popup will interfere with the GettingStarted dialog popup:

Meta
I'm Moving this ticket to the Editing Team's current workboard so we can discuss, and express an opinion about, the two approaches @Tgr proposed [i] to resolve the issue @Etonkovidova identified.[ii]


i. T235812#6635452
ii. T235812#6637842