Page MenuHomePhabricator

The Shan language cannot be found by its name in the Android app settings
Closed, ResolvedPublic

Description

The Shan Wikipedia is available in the Android app. I can find it by the name "Shan" if I go to the English Wikipedia article "Wikipedia" and click on the A文 button, then I can find it by the English name "Shan".

However, if I go to the app settings and try to add this language as a "Wikipedia language", then I cannot find it by the name "Shan", although I can find it by the language code "shn".

Event Timeline

Amire80 created this task.Oct 20 2019, 11:51 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Dbrant added a subscriber: Dbrant.Oct 21 2019, 3:20 PM

This seems to be working for me.
Are you sure you're using the latest app?

Oh, I think I know what's the deal. I'm using the phone in Hebrew, so I can search for "שאן", the Hebrew name of the language, but not in English.

Although it's kind of odd that I have to search in English in the article and I cannot use Hebrew, and it's vice versa in the settings!

Thanks @Amire80 for letting us know what the root cause was.

Charlotte closed this task as Resolved.Oct 22 2019, 4:17 PM

Well... I understand that now it's by design, but it should be fixed some day. On the desktop you can search for any language in any language.