Page MenuHomePhabricator

Too few arguments to function Wikibase\DataAccess\SingleEntitySourceServices::__construct(), 9 passed in /extensions/Wikibase/repo/includes/WikibaseRepo.php on line 2470 and exactly 10 expected
Closed, ResolvedPublic

Description

Error

MediaWiki version: 1.35.0-wmf.3

message
Too few arguments to function Wikibase\DataAccess\SingleEntitySourceServices::__construct(), 9 passed in /extensions/Wikibase/repo/includes/WikibaseRepo.php on line 2470 and exactly 10 expected

Impact

I see about 1400 of these for 1.35.0-wmf.3 on logstash right now. I fear that this means I'm going to treat this as a train blocker.

Notes

Details

Request ID
Xa2wUQpAMDsAAJQ3G4sAAACH
Request URL
/w/api.php
Stack Trace
exception.trace
#0 /extensions/Wikibase/repo/includes/WikibaseRepo.php(2470): Wikibase\DataAccess\SingleEntitySourceServices->__construct(Wikibase\DataAccess\GenericServices, Wikibase\DataModel\Entity\DispatchingEntityIdParser, Wikibase\DataModel\Services\EntityId\EntityIdComposer, DataValues\Deserializers\DataValueDeserializer, MediaWiki\Storage\NameTableStore, Wikibase\DataAccess\DataAccessSettings, Wikibase\DataAccess\EntitySource, array, array)
#1 /extensions/Wikibase/repo/includes/WikibaseRepo.php(2430): Wikibase\Repo\WikibaseRepo->newEntitySourceWikibaseServices()
#2 /extensions/Wikibase/repo/includes/WikibaseRepo.php(2149): Wikibase\Repo\WikibaseRepo->getWikibaseServices()
#3 /extensions/Wikibase/repo/RepoHooks.php(109): Wikibase\Repo\WikibaseRepo->getEntityNamespaceLookup()
#4 /includes/Hooks.php(174): Wikibase\RepoHooks::onSetupAfterCache()
#5 /includes/Hooks.php(202): Hooks::callHook(string, array, array, NULL)
#6 /includes/Setup.php(770): Hooks::run(string)
#7 /includes/WebStart.php(81): require_once(string)
#8 /api.php(36): require(string)
#9 /srv/mediawiki/w/api.php(3): require(string)
#10 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 24 2019, 11:59 AM
LarsWirzenius triaged this task as Unbreak Now! priority.Oct 24 2019, 12:00 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptOct 24 2019, 12:00 PM

@matthiasmullie That's must've been our backport. Looking into what went wrong.

I'll doublecheck, but I think these only happened the minute the patches were being scapped, and then stopped.

hashar added a subscriber: hashar.

Which is most probably closely related to T236370

Which is most probably closely related to T236370

That's basically the same code change, yes

These all happened at 11:10 UTC, when the change was being deployed. This stopped immediately after: https://logstash.wikimedia.org/goto/39611d534c6b97d76c367f4e4878ab15

WMDE-leszek added a comment.EditedOct 24 2019, 12:45 PM

@LarsWirzenius given what @matthiasmullie shows above, we believe it has been a hiccup caused by the backport of the breaking change in class constructor (some files got synced earlier than others) and is not a persistent issue.

OK, removing as blocker. Thanks!

LarsWirzenius lowered the priority of this task from Unbreak Now! to Low.Oct 24 2019, 12:46 PM
Krinkle closed this task as Resolved.Oct 25 2019, 1:25 AM
Krinkle claimed this task.