Page MenuHomePhabricator

`make install` fails with `“minikube-darwin-amd64” cannot be opened because the developer cannot be verified.`
Closed, ResolvedPublic

Description

This popup appears during make install.

popup.png (325×532 px, 62 KB)

The problem is resolved by clicking Allow Anyway in System Preferences > Security & Privacy

preferences.png (685×780 px, 127 KB)

Another make install will produce this popup. I have clicked Open.

popup-2.png (353×569 px, 71 KB)

make install still fails.

1~/Documents/gerrit/releng/local-charts$ make install
2(cd ./bin && ./install_prereqs.sh)
3Minikube already installed - Skipping minikube install step.
4Kubectl already installed - Skipping kubectl install step.
5Hyperkit already installed - Skipping hyperkit install step.
6Helm already installed - Skipping helm install step.
7Making hyperkit the default VM driver...
8⚠️ These changes will take effect upon a minikube delete and then a minikube start
9helm repo add wikimedia https://releases.wikimedia.org/charts/
10Error: Couldn't load repositories file (/Users/z/.helm/repository/repositories.yaml).
11You might need to run `helm init` (or `helm init --client-only` if tiller is already installed)
12make: *** [install] Error 1

make start fixed the problem.

Related Objects

Event Timeline

zeljkofilipin triaged this task as Medium priority.
zeljkofilipin moved this task from INBOX to Doing on the Release-Engineering-Team-TODO (201910) board.
zeljkofilipin moved this task from Backlog 🪒 to In Progress 🎸 on the User-zeljkofilipin board.

The problem is resolved by clicking Allow Anyway in System Preferences > Security & Privacy