Page MenuHomePhabricator

Identify container images and packages required for rook.io and ceph
Open, Needs TriagePublic

Description

Build a list of all container images and packages used for deploying and operating Ceph with rook.io

Event Timeline

JHedden created this task.Tue, Oct 29, 5:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptTue, Oct 29, 5:30 PM
JHedden renamed this task from Identify container images required for rook.io and ceph to Identify container images and packages required for rook.io and ceph.Tue, Oct 29, 9:08 PM
JHedden updated the task description. (Show Details)

OS Packages for Debian GNU/Linux 10 (buster) pulled from http://apt.wikimedia.org/wikimedia stretch-wikimedia thirdparty/kubeadm-k8s

containerd.io
cri-tools
docker-ce
docker-ce-cli
ipset
kubeadm
kubectl
kubernetes-cni

Container images currently pulled from external sources

ceph/ceph:v14.2.4-20190917
quay.io/cephcsi/cephcsi:v1.2.1
quay.io/k8scsi/csi-attacher:v1.2.0
quay.io/k8scsi/csi-node-driver-registrar:v1.1.0
quay.io/k8scsi/csi-provisioner:v1.3.0
quay.io/k8scsi/csi-snapshotter:v1.2.0
rook/ceph:v1.1.4