Page MenuHomePhabricator

Bundle esams-knams links back
Closed, ResolvedPublic

Description

During the onsite visit we split the 3*10Gbps LACP bundle landing on asw into 3*10G links landing on each cr as well as asw. This has the advantage if improving redundancy but the downside of reduced capacity (as we don't load balance traffic) has been overlooked.
This task is to move the 2 links terminating on cr2 and cr3 back to asw2-esams

https://netbox.wikimedia.org/circuits/circuits/43/
https://netbox.wikimedia.org/circuits/circuits/44/

  • Update Netbox and Homer to match new design
  • Optional: depool esams, if not, disable BGP to knams transits
  • Ensure knams is the backup path to eqiad
  • Downtime cr2-knams, cr2/3-esams
  • Move fibers:
oldnewdescription
cr3-esams:xe-0/0/4asw2-oe16-esams:xe-6/0/4Relined {SMF4303}
cr2-esams:xe-0/1/8asw2-oe15-esams:xe-5/0/4GBLX leg1 {SMF00297}
  • Configure bundle on asw2-esams
[edit interfaces xe-4/0/4]
-   mtu 9000;
+   ether-options {
+       802.3ad ae1;
+   }
[edit interfaces xe-4/0/4]
-    unit 0 {
-        family ethernet-switching {
-            interface-mode trunk;
-            vlan {
-                members [ XLink1 XLink3 ];
-            }
-        }
-    }
[edit interfaces]
+   xe-5/0/4 {
+       description "Core: cr2-knams:xe-0/0/0 (GBLX leg 1, SMF00297) {#10088} [10Gbps DF CWDM C61]";
+       ether-options {
+           802.3ad ae1;
+       }
+   }
+   xe-6/0/4 {
+       description "Core: cr2-knams:xe-0/0/3 (Relined, SMF4303) {#10701} [10Gbps DF CWDM C59]";
+       ether-options {
+           802.3ad ae1;
+       }
+   }
[edit interfaces ae1]
+   description cr2-knams:ae0;
-   disable;
+   mtu 9192;
+   unit 0 {
+       family ethernet-switching {
+           interface-mode trunk;
+           vlan {
+               members [ XLink1 XLink3 ];
+           }
+       }                               
+   }
  • Configure bundle on cr2-knams (already configured on new MX204 cr2-knams)
[edit interfaces xe-0/0/0]
-   description "Core: cr2-esams:xe-0/1/8 (GBLX leg 1) {#14006} [10Gbps DF CWDM C61]";
+   description "Core: asw2-esams:xe-5/0/4 (GBLX leg 1) {#14006} [10Gbps DF CWDM C61]";
-   mtu 9000;
+   gigether-options {
+       802.3ad ae0;
+   }
[edit interfaces xe-0/0/0]
-    unit 0 {
-        family inet {
-            address 91.198.174.224/31;
-        }
-        family inet6 {
-            address 2620:0:862:fe05::1/64;
-            address 2620:0:862:fe09::1/64;
-        }
-    }
[edit interfaces xe-0/0/3]
-   description "Core: cr3-esams:xe-0/0/4 (Relined, SMF4303) [10Gbps DF CWDM C59 cwdm1-knams]";
+   description "Core: asw2-esams:xe-6/0/4 (Relined, SMF4303) [10Gbps DF CWDM C59 cwdm1-knams]";
-   mtu 9000;
+   gigether-options {
+       802.3ad ae0;
+   }
[edit interfaces xe-0/0/3]
-    unit 0 {
-        family inet {
-            address 91.198.174.226/31;
-        }
-        family inet6 {
-            address 2620:0:862:fe08::1/128;
-        }
-    }
[edit interfaces xe-1/0/0]
-   description "Core: asw2-esams:xe-4/0/4 (GBLX leg 2) {#14007} [10Gbps DF CWDM C49]";
-   flexible-vlan-tagging;
-   mtu 9192;
-   encapsulation flexible-ethernet-services;
-   unit 401 {
-       description "Core: cr3-esams:ae1.401";
-       vlan-id 401;
-       family inet {
-           address 91.198.174.229/31;
-       }
-       family inet6 {
-           address 2620:0:862:fe01::2/64;
-       }
-   }
-   unit 403 {
-       description "Core: cr2-esams:ae1.403";
-       vlan-id 403;
-       family inet {
-           address 91.198.174.255/31;
-       }
-       family inet6 {
-           address 2620:0:862:fe03::2/64;
-       }
-   }
+   description "Core: asw2-esams:xe-4/0/4 (GBLX leg 2) {#14007} [10Gbps DF CWDM C49]";
[edit interfaces ae0]
+   description asw2-esams:ae1;
-   disable;
+   flexible-vlan-tagging;
+   mtu 9192;
+   encapsulation flexible-ethernet-services;
+   unit 401 {
+       description "Core: cr3-esams:ae1.401";
+       vlan-id 401;
+       family inet {
+           address 91.198.174.229/31;
+       }
+       family inet6 {
+           address 2620:0:862:fe01::2/64;
+       }
+   }
+   unit 403 {
+       description "Core: cr2-esams:ae1.403";
+       vlan-id 403;
+       family inet {                   
+           address 91.198.174.255/31;
+       }
+       family inet6 {
+           address 2620:0:862:fe03::2/64;
+       }
+   }
[edit protocols ospf area 0.0.0.0]
      interface xe-1/1/0.13 { ... }
+     interface ae0.401 {
+         interface-type p2p;
+         bfd-liveness-detection {
+             minimum-interval 300;
+         }
+     }
+     interface ae0.403 {
+         interface-type p2p;
+         bfd-liveness-detection {
+             minimum-interval 300;
+         }
+     }
      interface lo0.0 { ... }
[edit protocols ospf area 0.0.0.0]
-     interface xe-1/0/0.401 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
-     interface xe-1/0/0.403 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
-     interface xe-0/0/0.0 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }                             
-     }
-     interface xe-0/0/3.0 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
[edit protocols ospf3 area 0.0.0.0]
      interface xe-1/1/0.13 { ... }
+     interface ae0.401 {
+         interface-type p2p;
+         bfd-liveness-detection {
+             minimum-interval 300;
+         }
+     }
+     interface ae0.403 {
+         interface-type p2p;
+         bfd-liveness-detection {
+             minimum-interval 300;
+         }
+     }
      interface lo0.0 { ... }
[edit protocols ospf3 area 0.0.0.0]
-     interface xe-1/0/0.401 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
-     interface xe-1/0/0.403 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
-     interface xe-0/0/0.0 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;     
-         }
-     }
-     interface xe-0/0/3.0 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
[edit protocols pim]
+    interface ae0.401;
     interface xe-1/1/0.13 { ... }
[edit protocols pim]
     interface xe-1/1/0.23 { ... }
+    interface ae0.403;
-    interface xe-1/0/0.401;
-    interface xe-1/0/0.403;
  • Cleanup configuration on cr3-esams
[edit interfaces]
-   xe-0/0/4 {
-       description "Core: cr2-knams:xe-0/0/3 (Relined, SMF4303) {#10701} [10Gbps DF CWDM C59]";
-       mtu 9000;
-       unit 0 {
-           family inet {
-               address 91.198.174.227/31;
-           }
-           family inet6 {
-               address 2620:0:862:fe08::2/128;
-           }
-       }
-   }
[edit protocols ospf area 0.0.0.0]
-     interface xe-0/0/4.0 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
[edit protocols ospf3 area 0.0.0.0]
-     interface xe-0/0/4.0 {
-         interface-type p2p;
-         bfd-liveness-detection {      
-             minimum-interval 300;
-         }
-     }
  • Cleanup configuration on cr2-esams
[edit interfaces]
-   xe-0/1/8 {
-       description "Core: cr2-knams:xe-0/0/0 (GBLX leg 1, SMF00297) {#10088} [10Gbps DF CWDM C61]";
-       mtu 9000;
-       unit 0 {
-           family inet {
-               address 91.198.174.225/31;
-           }
-           family inet6 {
-               address 2620:0:862:fe05::2/64;
-               address 2620:0:862:fe09::2/64;
-           }
-       }
-   }
[edit protocols ospf area 0.0.0.0]
-     interface xe-0/1/8.0 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
[edit protocols ospf3 area 0.0.0.0]
-     interface xe-0/1/8.0 {
-         interface-type p2p;
-         bfd-liveness-detection {
-             minimum-interval 300;
-         }
-     }
  • Run Homer to ensure configuration is correct
  • Ensure monitoring is happy
  • repool esams, or enable BGP to knams transits
  • Cleanup old IPs from DNS

Details

Related Gerrit Patches:

Related Objects

Event Timeline

ayounsi triaged this task as Medium priority.Oct 31 2019, 3:22 PM
ayounsi created this task.
Restricted Application added a project: Operations. · View Herald TranscriptOct 31 2019, 3:22 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
ayounsi updated the task description. (Show Details)Wed, Nov 13, 8:45 PM

Mentioned in SAL (#wikimedia-operations) [2019-11-25T12:27:29Z] <XioNoX> disable BGP to knams transits - T237031

Mentioned in SAL (#wikimedia-operations) [2019-11-25T12:42:31Z] <XioNoX> bundle esams-knams links on esams side - T237031

Mentioned in SAL (#wikimedia-operations) [2019-11-25T12:48:02Z] <XioNoX> bundle esams-knams links on knams side - T237031

Mentioned in SAL (#wikimedia-operations) [2019-11-25T13:06:36Z] <XioNoX> cleanup config on cr2-esams - T237031

Mentioned in SAL (#wikimedia-operations) [2019-11-25T13:16:55Z] <XioNoX> cleanup config on cr3-esams - T237031

Change 552851 had a related patch set uploaded (by Ayounsi; owner: Ayounsi):
[operations/dns@master] Remove old cr2-knams <-> cr2/3-esams links

https://gerrit.wikimedia.org/r/552851

Change 552851 merged by Ayounsi:
[operations/dns@master] Remove old cr2-knams <-> cr2/3-esams links

https://gerrit.wikimedia.org/r/552851

ayounsi closed this task as Resolved.Mon, Nov 25, 4:39 PM
ayounsi claimed this task.

All done. Not re-enabling knams transits as we're setting up the new MX204 right now.