Page MenuHomePhabricator

UploadWizard Upload interface messed up
Closed, ResolvedPublic

Description

The Upload interface (step 2) in UploadWizard is messed up and some important parts of the UI are not visible to the user.

What it currently looks like:

What it used to look like:

Note that this affects all file uploads, not just duplicate files as shown in the screenshots above.

Confirmed in both Chrome and Firefox with multiple skins in safe mode.

Details

Related Gerrit Patches:
mediawiki/extensions/UploadWizard : wmf/1.35.0-wmf.4Fixing DOM in upload interface of UploadWizard
mediawiki/extensions/UploadWizard : masterFixing DOM in upload interface of UploadWizard

Event Timeline

kaldari created this task.Fri, Nov 1, 6:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFri, Nov 1, 6:28 PM

@matthiasmullie @Volker_E - No idea what caused this, but any chance one of you could look into this?

kaldari updated the task description. (Show Details)Fri, Nov 1, 6:31 PM
kaldari updated the task description. (Show Details)Fri, Nov 1, 8:01 PM
kaldari updated the task description. (Show Details)

It looks like the placement of the mwe-upwiz-file-texts div in the DOM has changed.

Old DOM:

New DOM:

Looks like @Esanders inadvertently broke it while making the code more linter compliant:
https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/UploadWizard/+/541298/1/resources/mw.UploadWizardUploadInterface.js

Note the sneaky self closing div on line 30 that was accidentally changed into an opening div tag.

Change 547783 had a related patch set uploaded (by Kaldari; owner: Kaldari):
[mediawiki/extensions/UploadWizard@master] Fixing DOM in upload interface of UploadWizard

https://gerrit.wikimedia.org/r/547783

Change 547783 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Fixing DOM in upload interface of UploadWizard

https://gerrit.wikimedia.org/r/547783

Thanks for the fix!

Change 547794 had a related patch set uploaded (by Jforrester; owner: Kaldari):
[mediawiki/extensions/UploadWizard@wmf/1.35.0-wmf.4] Fixing DOM in upload interface of UploadWizard

https://gerrit.wikimedia.org/r/547794

Change 547794 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@wmf/1.35.0-wmf.4] Fixing DOM in upload interface of UploadWizard

https://gerrit.wikimedia.org/r/547794

Mentioned in SAL (#wikimedia-operations) [2019-11-01T21:20:35Z] <jforrester@deploy1001> Synchronized php-1.35.0-wmf.4/extensions/UploadWizard/resources/mw.UploadWizardUploadInterface.js: T237126 Fixing DOM in upload interface of UploadWizard (duration: 00m 56s)

Jdforrester-WMF closed this task as Resolved.Fri, Nov 1, 9:21 PM
Jdforrester-WMF assigned this task to kaldari.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Deployed. Thanks!