Page MenuHomePhabricator

Missing and incorrect "Select an option to add it at the cursor" item
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce & Actual Results

  • There's no if <cond-expr> then <then-expr> end syntax on the list
  • If we click if X then Y else Z entry, the following text appear: if cond then iftrue elseiffalse end

Expected Results:

  • There should be if <cond-expr> then <then-expr> end entry.
  • if X then Y else Z should be changed to if X then Y else Z end
  • if cond then iftrue elseiffalse end should be changed to if cond then iftrue else iffalse end

Details

Related Gerrit Patches:
mediawiki/extensions/AbuseFilter : masterFix conditionals examples in i18n messages

Event Timeline

Nullzero created this task.Nov 1 2019, 7:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 1 2019, 7:13 PM
Daimona added a subscriber: Daimona.Nov 1 2019, 7:19 PM

OK, so, these are all easy fixes. In particular:

  • Adding "if then end" - this is missing because if's without else were only introduced recently.
  • Missing "end" - trivial change
  • Missing space - same.

Change 547862 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] Fix conditionals examples in i18n messages

https://gerrit.wikimedia.org/r/547862

Daimona claimed this task.Nov 2 2019, 10:32 AM

Change 547862 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Fix conditionals examples in i18n messages

https://gerrit.wikimedia.org/r/547862

Nullzero closed this task as Resolved.Nov 10 2019, 11:09 AM
Nullzero removed a project: Patch-For-Review.