Page MenuHomePhabricator

paws-public.wmflabs.org returns 502 Bad Gateway
Closed, ResolvedPublic

Event Timeline

from paws-proxy-02.paws.eqiad.wmflabs:/var/log/nginx/error.log:
upstream: "https://172.16.6.39:443/paws-public/User:Lucas_Werkmeister_(WMDE)/"

But:

# host 172.16.6.39
Host 39.6.16.172.in-addr.arpa. not found: 3(NXDOMAIN)

I believe this used to be proxied through the tools project, so potentially caused by T235627?

Krenair closed this task as Resolved.Nov 2 2019, 12:14 PM
Krenair claimed this task.

I sorted this and cleaned up two other cases of hardcoded IPs in the config:

root@paws-proxy-02:~# grep proxy_pass /etc/nginx/sites-enabled/default 
#		proxy_pass https://172.16.6.39;
		proxy_pass https://tools.wmflabs.org;
#		proxy_pass http://172.16.5.206:32611;
		proxy_pass http://tools-paws-worker-1006.tools.eqiad.wmflabs:32611;
#		proxy_pass http://172.16.5.206:32612;
		proxy_pass http://tools-paws-worker-1006.tools.eqiad.wmflabs:32612;
root@paws-proxy-02:~#

(I believe these instances are largely unpuppetised)