Page MenuHomePhabricator

Vertical alignment regressions in desktop link contexts
Closed, ResolvedPublic

Description

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterUpdate VE core submodule to master (a6ef2cc7d)
VisualEditor/VisualEditor : masterTweak alignment of frameless button in desktop context further
mediawiki/extensions/VisualEditor : masterUpdate VE core submodule to master (8cba52aa6)
VisualEditor/VisualEditor : masterFix alignment of frameless button in desktop context
VisualEditor/VisualEditor : masterFix vertical alignment in LinkContextItem

Event Timeline

Esanders created this task.Nov 4 2019, 5:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 4 2019, 5:59 PM

Bisect unsurprisingly blames an OOUI update. v0.35.1 :)

Change 548467 had a related patch set uploaded (by Esanders; owner: Esanders):
[VisualEditor/VisualEditor@master] Fix alignment of frameless button in desktop context

https://gerrit.wikimedia.org/r/548467

Change 548469 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[VisualEditor/VisualEditor@master] Fix vertical alignment in LinkContextItem

https://gerrit.wikimedia.org/r/548469

Seems to be caused by the addition of min-height in https://gerrit.wikimedia.org/r/c/oojs/ui/+/514970/19/src/themes/wikimediaui/elements.less , removing that rule fixes it.

It does, but the height addition is useful in increasing the click target, so I added negative margin instead.

Change 548469 abandoned by VolkerE:
Fix vertical alignment in LinkContextItem

Reason:
for I59a4d1a4e6ac18e60916b31855634ba552bea9c8

https://gerrit.wikimedia.org/r/548469

Change 548467 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Fix alignment of frameless button in desktop context

https://gerrit.wikimedia.org/r/548467

Change 548484 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (5f0d866a0)

https://gerrit.wikimedia.org/r/548484

Change 548485 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[VisualEditor/VisualEditor@master] Tweak alignment of frameless button in desktop context further

https://gerrit.wikimedia.org/r/548485

Change 548484 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (8cba52aa6)

https://gerrit.wikimedia.org/r/548484

Change 548485 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Tweak alignment of frameless button in desktop context further

https://gerrit.wikimedia.org/r/548485

Change 549651 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (a6ef2cc7d)

https://gerrit.wikimedia.org/r/549651

Change 549651 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (a6ef2cc7d)

https://gerrit.wikimedia.org/r/549651

ppelberg closed this task as Resolved.Dec 24 2019, 7:15 PM
ppelberg claimed this task.