Page MenuHomePhabricator

Update elasticsearch/elasticsearch and ruflin/elastica
Closed, ResolvedPublic

Description

https://gerrit.wikimedia.org/r/#/c/mediawiki/vendor/+/542307/ proposed to:

ruflin/elastica from 6.0.2 to 6.1.1

  • 6.x branch is good with ES ^6.0 and PHP ^7.0

elasticsearch/elasticsearch from 6.0.1.0 to 6.5.1

  • 6.5.x branch is good with ES >= 6.0, < 6.6 and PHP ^7.0

As we're not limited to needing HHVM specific code now, and we've migrated back to the non forks.. But we should be able to update to later releases that support our ES versions