Page MenuHomePhabricator

[Bug] Active discussions message and "Read as wiki page" button appears on Minerva Desktop talk pages on Beta
Closed, ResolvedPublic2 Estimated Story PointsBUG REPORT

Description

Steps to reproduce

  1. Login and visit https://en.wikipedia.beta.wmflabs.org/wiki/Talk:Dog?useskin=Minerva&useformat=desktop (or any regular talk page on desktop minerva skin)

Expected results

  • I don't expect to see a "Read as wiki page" button as the simplified section view from T230695 is not shown. Clicking on the button just reveals the table of contents which is confusing.
  • I also don't expect to see the "Active discussions" message as it seems out of place since the simplified view from T230695 is not shown.

Actual results

Check any additional observations

Dev notes

The "Active discussions" message and "Read as wiki page" button were added as part of the render talk as tab task (T230695)

The "Active discussions" message is appended in SkinMinerva.php:
https://github.com/wikimedia/mediawiki-skins-MinervaNeue/blob/10defb5aa15203c7fb657a194f7dcf4df3c1233a/includes/skins/SkinMinerva.php#L510-L532

The "Read as wiki page" button is appended in skins.minerva.scripts/talk.js:
https://github.com/wikimedia/mediawiki-skins-MinervaNeue/blob/10defb5aa15203c7fb657a194f7dcf4df3c1233a/resources/skins.minerva.scripts/talk.js#L148-L165

The next question is what is the cleanest way to turn these things off on minerva desktop talk pages. Note that we still want the "Add discussions" button to show which is added in the same method as the "Active Discussions" message.

QA steps

QA results

T237597#5722986

When logged in user visits a talk page on desktop Minerva

  1. Login and visit https://en.wikipedia.beta.wmflabs.org/wiki/Talk:Dog?useskin=Minerva&useformat=desktop
  2. Ensure that there is NOT an "Read as wikipage" button, "There are no discussions on this page" message, or "Active discussions" message visible on the page.
  3. Ensure that there is a blue "Add discussion" button
  4. Ensure the table of contents shows on wider screens
  5. Ensure that no overlay is shown when clicking on a section. Note that the section will NOT collapse/expan5

Event Timeline

nray created this task.Nov 7 2019, 1:00 AM
Restricted Application added subscribers: Masumrezarock100, Aklapper. · View Herald TranscriptNov 7 2019, 1:00 AM
nray renamed this task from [Bug] Active discussions message and "Read as wikipage" button appears on Minerva Desktop talk pages on Beta to [Bug] Active discussions message and "Read as wiki page" button appears on Minerva Desktop talk pages on Beta.Nov 7 2019, 1:00 AM
ovasileva triaged this task as Medium priority.Nov 7 2019, 12:29 PM
ovasileva set the point value for this task to 2.Nov 7 2019, 6:52 PM

Change 550729 had a related patch set uploaded (by Nray; owner: Nray):
[mediawiki/skins/MinervaNeue@master] Disable Simplified Talk Page on Flow Talk Pages

https://gerrit.wikimedia.org/r/550729

Change 550736 had a related patch set uploaded (by Nray; owner: Nray):
[mediawiki/extensions/MobileFrontend@master] Add public hasExpandableSections to MobileFormatter for use with MobileFrontendBeforeDOM hook

https://gerrit.wikimedia.org/r/550736

nray added a comment.Nov 13 2019, 7:12 PM

It turns out that the fix for T237589 should also fix this ticket which is why there is a gerrit patch associated with this ticket now.

Change 550736 abandoned by Nray:
Move MobileFrontendBeforeDOM hook

Reason:
I misread the code!

https://gerrit.wikimedia.org/r/550736

Change 550729 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Enable Simplified Talk Page only on Pages With Expandable Sections

https://gerrit.wikimedia.org/r/550729

nray assigned this task to Edtadros.Nov 26 2019, 12:18 AM
nray updated the task description. (Show Details)
nray updated the task description. (Show Details)
nray updated the task description. (Show Details)Nov 26 2019, 10:59 PM
ovasileva added a subscriber: ovasileva.

QA

  1. Login and visit https://en.wikipedia.beta.wmflabs.org/wiki/Talk:Dog?useskin=Minerva&useformat=desktop
  2. Ensure that there is NOT an "Read as wikipage" button, "There are no discussions on this page" message, or "Active discussions" message visible on the page.
    • none of the above are visible
  1. Ensure that there is a blue "Add discussion" button

  1. Ensure the table of contents shows on wider screens
    • TOC appears (see screenshot above)
  2. Ensure that no overlay is shown when clicking on a section. Note that the section will NOT collapse/expan5
    • confirmed

Working as expected, moving to signoff

ovasileva updated the task description. (Show Details)Dec 9 2019, 10:55 AM
ovasileva updated the task description. (Show Details)
ovasileva closed this task as Resolved.Dec 9 2019, 6:43 PM

Resolving