Page MenuHomePhabricator

cloud-cumin-01: HTTPSConnectionPool - Max retries exceeded with url
Closed, InvalidPublic

Description

Running a cumin query on deployment-cumin02:

dzahn@deployment-cumin02:~$ sudo cumin -i 'P{R:Class = puppetmaster}' 'lsb_release -c'
...
2 hosts will be targeted:
deployment-dumps-puppetmaster02.deployment-prep.eqiad.wmflabs,deployment-puppetmaster03.deployment-prep.eqiad.wmflabs
Confirm to continue [y/n]? y

Running the same command on cloud-cumin-01 (to get the information for all projects):

dzahn@cloud-cumin-01:~$ sudo cumin -i 'P{R:Class = puppetmaster}' 'lsb_release -c'
Caught ConnectionError exception: HTTPSConnectionPool(host='localhost', port=443): Max retries exceeded with url: /pdb/query/v4/resources (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7fbefe827da0>: Failed to establish a new connection: [Errno 111] Connection refused',))

Event Timeline

Dzahn created this task.Nov 7 2019, 9:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 7 2019, 9:13 PM
Krenair added a subscriber: Krenair.Nov 7 2019, 9:18 PM

Cloud-cumin's domain is the whole of labs, it doesn't have a PuppetDB. I
wonder what it's trying to connect to...

bd808 added a subscriber: bd808.Nov 7 2019, 9:33 PM

Cumin targeting in Cloud VPS is different than production as @Krenair points out because the shared Cloud VPS Puppet deployment does not include PuppetDB. The backend that we do have is documented at https://wikitech.wikimedia.org/wiki/Cumin#OpenStack_backend

Dzahn closed this task as Invalid.Nov 7 2019, 9:35 PM

Ok. The thing i actually want is a list of all instances using a certain class. (List of puppetmasters on jessie). I will keep using openstack-browser then.

Volans added a subscriber: Volans.Nov 8 2019, 5:23 PM

@Krenair the default ones HTTPSConnectionPool(host='localhost', port=443)
@Dzahn that would be T179816, but it seems that there haven't been much interest in that backend.