Page MenuHomePhabricator

Newcomer tasks - the articles cards change without user interaction
Closed, ResolvedPublic

Description

  1. On Homepage click on difficulty filter button, the selection of filters overlay will open.
  2. Move the cursor(without clicking) to the overlay area - the article card in Suggested edits will change.
  3. Close the difficulty filter selection overlay and hover the cursor (without clicking) on the difficulty filter button - the card will change again.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 7 2019, 11:06 PM
Etonkovidova updated the task description. (Show Details)Nov 7 2019, 11:08 PM
Etonkovidova updated the task description. (Show Details)Nov 7 2019, 11:13 PM

When a article card changes - there will be three url requests present
e.g.

https://cs.wikipedia.org/w/api.php?action=query&format=json&prop=info%7Cpageviews%7Cpageimages&inprop=protection%7Curl&pvipdays=1&pithumbsize=260&generator=growthtasks&ggttasktypes=copyedit%7Clinks%7Creferences%7Cupdate%7Cexpand&formatversion=2&uselang=cs

https://cs.wikipedia.org/api/rest_v1/page/summary/1955

https://cs.wikipedia.org/api/rest_v1/page/summary/%C4%8Cesk%C3%A1%20a%20Slovensk%C3%A1%20Federativn%C3%AD%20Republika
kostajh added a subscriber: kostajh.Nov 8 2019, 7:48 AM

Is this on testwiki?

@Etonkovidova I assume yes. Please try to reproduce on beta. The reason this occurs on testwiki is because an older version of the code performed a search when the difficulty dialog was opened and again when it was closed. In the latest code, a search isn't performed when the filters are opened/closed.

JTannerWMF moved this task from Backlog to Doing on the NewcomerTasks 1.0 board.Nov 8 2019, 6:18 PM
Etonkovidova closed this task as Resolved.Nov 8 2019, 11:35 PM
Etonkovidova claimed this task.

Re-checked - the issue does not present on beta, but it's still on testwiki. I'll add this to the list of what should be checked after the next deployment.