Page MenuHomePhabricator

Create Shawiya Wiktionary
Closed, ResolvedPublic

Description

The language committee has approved the creation of the Shawiya (Tacawit) Wikipedia:

Request page: https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wiktionary_Tacawit
Language code: shy-latn
Site URL: shy.wiktionary.org
Project name: Wikasegzawal
Project namespace: Wikasegzawal
Project talk namespace: Wikasegzawal_tameslayt (default)
Project logo: https://commons.wikimedia.org/wiki/File:WiktionaryShy.svg
Timezone: Africa/Algiers

Details

Related Gerrit Patches:
operations/mediawiki-config : masterRename shy-latn to shy in langlist
operations/mediawiki-config : masterSet correct language for shywiktionary
operations/mediawiki-config : masterAdd shywiktionary to wikiversions.json
operations/mediawiki-config : masterInitial configuration for shywiktionary
mediawiki/extensions/WikimediaMessages : masterFollow-up: Rename shy_latnwiktionary to shywiktionary
mediawiki/extensions/WikimediaMessages : masterAdd soon-to-be-created wikis into WikimediaMessages
operations/dns : masterAdd gcr and shy languages

Event Timeline

jhsoby created this task.Tue, Nov 12, 4:37 PM
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptTue, Nov 12, 4:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 550511 had a related patch set uploaded (by Jon Harald Søby; owner: Jon Harald Søby):
[operations/dns@master] Add gcr and shy languages

https://gerrit.wikimedia.org/r/550511

Note: This would be the very first Wikimedia language project where the Wikipedia is not the first project to be created. Could there be any unforeseen consequences to that (if we knew, they wouldn't be unforeseen, but you know what I mean)?

Ladsgroup changed the status of subtask T238120: Add Wikidata support for shywiktionary from Open to Stalled.Wed, Nov 13, 2:19 PM

Change 550511 merged by Dzahn:
[operations/dns@master] Add gcr and shy languages

https://gerrit.wikimedia.org/r/550511

Dzahn added a subscriber: Dzahn.Wed, Nov 13, 2:46 PM

added to DNS:

shy.wikipedia.org is an alias for dyna.wikimedia.org.

Dzahn changed the status of subtask T238123: Add shywiktionary to wikistats from Open to Stalled.Thu, Nov 14, 5:00 PM

Change 551973 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/WikimediaMessages@master] Add soon-to-be-created wikis into WikimediaMessages

https://gerrit.wikimedia.org/r/551973

Change 551973 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Add soon-to-be-created wikis into WikimediaMessages

https://gerrit.wikimedia.org/r/551973

Change 552021 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Initial configuration for shywiktionary

https://gerrit.wikimedia.org/r/552021

Urbanecm moved this task from Backlog to Wikis ready for creation on the User-Urbanecm board.
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptWed, Nov 20, 9:36 AM

Change 552060 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/WikimediaMessages@master] Follow-up: Rename shy_latnwiktionary to shywiktionary

https://gerrit.wikimedia.org/r/552060

Change 552060 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Follow-up: Rename shy_latnwiktionary to shywiktionary

https://gerrit.wikimedia.org/r/552060

Urbanecm triaged this task as Low priority.Wed, Nov 20, 12:24 PM

Change 552021 merged by jenkins-bot:
[operations/mediawiki-config@master] Initial configuration for shywiktionary

https://gerrit.wikimedia.org/r/552021

Mentioned in SAL (#wikimedia-operations) [2019-11-20T22:59:46Z] <ladsgroup@deploy1001> Synchronized dblists: T238105 (duration: 00m 53s)

Change 552152 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Add shywiktionary to wikiversions.json

https://gerrit.wikimedia.org/r/552152

Change 552152 merged by jenkins-bot:
[operations/mediawiki-config@master] Add shywiktionary to wikiversions.json

https://gerrit.wikimedia.org/r/552152

Mentioned in SAL (#wikimedia-operations) [2019-11-20T23:05:50Z] <ladsgroup@deploy1001> rebuilt and synchronized wikiversions files: T238105

Mentioned in SAL (#wikimedia-operations) [2019-11-20T23:08:00Z] <ladsgroup@deploy1001> Synchronized multiversion/MWMultiVersion.php: T238105 (duration: 00m 51s)

Mentioned in SAL (#wikimedia-operations) [2019-11-20T23:09:06Z] <ladsgroup@deploy1001> Synchronized wmf-config/InitialiseSettings.php: T238105 (duration: 00m 51s)

Mentioned in SAL (#wikimedia-operations) [2019-11-20T23:10:20Z] <ladsgroup@deploy1001> Synchronized static/images/project-logos/: T238105 (duration: 00m 52s)

Mentioned in SAL (#wikimedia-operations) [2019-11-20T23:11:25Z] <ladsgroup@deploy1001> Synchronized langlist: T238105 (duration: 00m 50s)

Ladsgroup closed this task as Resolved.Wed, Nov 20, 11:15 PM
Ladsgroup changed the status of subtask T238120: Add Wikidata support for shywiktionary from Stalled to Open.Wed, Nov 20, 11:19 PM

Change 552159 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Set correct language for shywiktionary

https://gerrit.wikimedia.org/r/552159

Dcljr added a subscriber: Dcljr.Thu, Nov 21, 10:21 AM

Note that visiting https://shy.wiktionary.org/ does not bring up the existing local main page https://shy.wiktionary.org/wiki/Amzawru_Tasfhit (created about 11 hours ago by 127.0.0.1 when the wiki was created). I'm not sure if this is a sign of a "deeper" problem or (at the other extreme) if it's to be expected at this point in the process.....

Note that visiting https://shy.wiktionary.org/ does not bring up the existing local main page https://shy.wiktionary.org/wiki/Amzawru_Tasfhit (created about 11 hours ago by 127.0.0.1 when the wiki was created). I'm not sure if this is a sign of a "deeper" problem or (at the other extreme) if it's to be expected at this point in the process.....

Yeah, that'll most likely be fixed (along with correcting the names paces) by Amir's config patch above. We forgot that since the domain language code is not equal to the localisation language code (which has "-latn" as well), we need to set it explicitly in config.

Change 552159 merged by jenkins-bot:
[operations/mediawiki-config@master] Set correct language for shywiktionary

https://gerrit.wikimedia.org/r/552159

Mentioned in SAL (#wikimedia-operations) [2019-11-21T11:08:03Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: e4861ec: Set correct language for shywiktionary (T238105) (duration: 00m 52s)

Note that visiting https://shy.wiktionary.org/ does not bring up the existing local main page https://shy.wiktionary.org/wiki/Amzawru_Tasfhit [...]

Yeah, that'll most likely be fixed [...] by Amir's config patch above.

Yes, now fixed.

Hello all the correct name of the language for wikidata and other places is Tacawit not Tachawit.
Correct this please

If there is something wrong in some places somewhere, then please provide clear links / name of places, so others do not have to guess what you mean.
@Vikoula5: Please see https://www.mediawiki.org/wiki/How_to_report_a_bug - thanks.

Raymond reopened this task as Open.Fri, Nov 22, 8:51 AM
Raymond added a subscriber: Raymond.

Also, it doesn't appear in the right place in [[Special:SiteMatrix]]. Possibly related?

Change 552478 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Rename shy-latn to shy in langlist

https://gerrit.wikimedia.org/r/552478

Change 552478 merged by jenkins-bot:
[operations/mediawiki-config@master] Rename shy-latn to shy in langlist

https://gerrit.wikimedia.org/r/552478

Mentioned in SAL (#wikimedia-operations) [2019-11-22T09:56:46Z] <ladsgroup@deploy1001> Synchronized langlist: T238105 (duration: 00m 51s)

Ladsgroup closed this task as Resolved.Fri, Nov 22, 10:11 AM
Dzahn changed the status of subtask T238123: Add shywiktionary to wikistats from Stalled to Open.Fri, Nov 22, 7:36 PM
Raymond reopened this task as Open.Sat, Nov 23, 2:58 PM

Something still wrong with the interwiki. [[:shy:wikt:Asebtar amenzu]] redirects to https://incubator.wikimedia.org/wiki/Wp/shy?goto=mainpage instead to the newly created Wiktionary in Shawiya.

Test page: https://test.wikipedia.org/wiki/User:Raymond/interwikis

Something still wrong with the interwiki. [[:shy:wikt:Asebtar amenzu]] redirects to https://incubator.wikimedia.org/wiki/Wp/shy?goto=mainpage instead to the newly created Wiktionary in Shawiya.
Test page: https://test.wikipedia.org/wiki/User:Raymond/interwikis

It's because this wiki doesn't have a Wikipedia. It's only a wiktionary now. Using [[:wikt:shy:Asebtar amenzu]] would fix it (first going to English Wiktionary and then going to shy wiktionary instead of going to shy Wikipedia (which doesn't exist) then trying to go to shywiktionary.

jhsoby added a comment.EditedSat, Nov 23, 4:48 PM

Something still wrong with the interwiki. [[:shy:wikt:Asebtar amenzu]] redirects to https://incubator.wikimedia.org/wiki/Wp/shy?goto=mainpage instead to the newly created Wiktionary in Shawiya.
Test page: https://test.wikipedia.org/wiki/User:Raymond/interwikis

It's because this wiki doesn't have a Wikipedia. It's only a wiktionary now. Using [[:wikt:shy:Asebtar amenzu]] would fix it (first going to English Wiktionary and then going to shy wiktionary instead of going to shy Wikipedia (which doesn't exist) then trying to go to shywiktionary.

Just to add to this, this is expected behaviour for any kind of link like that. If you want to link to e.g. the Igbo Wikipedia from any Wikibooks project, you will also have to do [[w:ig:]] instead of [[:ig:w:]]. Always use the project prefix before the language prefix.

Dcljr added a comment.EditedSun, Nov 24, 2:48 AM

Continuing off-topic discussion: Note that you can also do [[m:wikt:shy:]] from any Wikimedia wiki (to go through the Meta-Wiki first), to deal with cases where [[wikt:shy:]] doesn't work (e.g., following a link to [[wikt:shy:]] from the newly-created Sakizaya Wikipedia, lands you on a page at the Incubator).

Ladsgroup closed this task as Resolved.Mon, Nov 25, 12:51 PM

I close this, for the love of Jimmy don't open it. If there's an issue with the setup, please file another bug. The main task (creating the wiki) is done.