Page MenuHomePhabricator

mediawiki Template:Extension cannot access to file config => Project not found in Phabricator
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:

  1. go to page => https://www.mediawiki.org/wiki/Template:Extension
  2. in second paragraph go to parameter 'translate'
  3. click on link 'config' of 'ext-LOWERCASE(NOSPACES(Label as defined in config)), aka'

Actual Results:
we get in Phabricator "The requested project does not exist" followed by a long list of items
as the result of request => {{git file|project=translwikmediadef|branch=HEAD|file=groups/MediaWiki/mediawiki-defines.txt|text=config}}
generating link => https://phabricator.wikimedia.org//r/p/translwikmediadef;browse/master/groups/MediaWiki/mediawiki-defines.txt

Expected Results:
access is expected to config file to read the label

References:
-talk on https://www.mediawiki.org/wiki/Topic:Vbl1f0pa0wjwlo00
-similar error observed for docs/settings.md ; see => https://phabricator.wikimedia.org/T237288

Event Timeline

Wladek92 created this task.Fri, Nov 22, 2:33 PM
Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptFri, Nov 22, 2:33 PM
Reedy added a subscriber: Reedy.Fri, Nov 22, 2:35 PM

as the result of request => {{git file|project=translwikmediadef|branch=HEAD|file=groups/MediaWiki/mediawiki-defines.txt|text=config}}
generating link => https://phabricator.wikimedia.org//r/p/translwikmediadef;browse/master/groups/MediaWiki/mediawiki-defines.txt

The "callsign" for Extension:Translate is https://phabricator.wikimedia.org/diffusion/ETRA/

Wladek92 updated the task description. (Show Details)Fri, Nov 22, 2:54 PM

@Wladek92: I do not understand how or why this issue is different from T237288: Extension:AdvancedSearch cannot access to docs/settings.md => Project not found in Phabricator . Can you please elaborate?

Ciencia_Al_Poder closed this task as Invalid.Fri, Nov 22, 6:21 PM
Ciencia_Al_Poder added a subscriber: Ciencia_Al_Poder.

The link pointed to translwikmediadef repository, which doesn't seem to exist (or at least not with that name). I've changed the link to the "translatewiki" repository (and a different file since that one no longer exists) and now the URL resolves properly. I don't know when the repo was renamed from translwikmediadef, however there doesn't seem to be many links to that repo. I think there's no need for a redirect. But this particular issue with the template is fixed

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptFri, Nov 22, 6:21 PM