Page MenuHomePhabricator

New users get both ReferenceTooltips (gadget) and ReferencePreviews (Beta feature)
Closed, ResolvedPublic

Description

https://www.mediawiki.org/wiki/Help:Reference_Previews should not be enabled in ruwiki because for many years in ruwiki for all users, including unregistered, a better gadget https://www.mediawiki.org/wiki/Reference_Tooltips was enabled. Now new users have enabled both gadgets and their tooltips overlap one another, but unregistered users have only Reference Tooltips.

Event Timeline

MBH created this task.Nov 23 2019, 6:12 PM
Restricted Application added subscribers: Base, Aklapper. · View Herald TranscriptNov 23 2019, 6:12 PM
Zoranzoki21 changed the task status from Open to Stalled.Nov 23 2019, 8:17 PM
Zoranzoki21 claimed this task.
Zoranzoki21 added a subscriber: Zoranzoki21.

You need to provide community consensus for configuration changes.

Restricted Application added a project: User-Zoranzoki21. · View Herald TranscriptNov 23 2019, 8:17 PM
Aklapper removed Zoranzoki21 as the assignee of this task.Nov 24 2019, 12:48 AM

Thanks for the feedback. Looking at https://meta.wikimedia.org/wiki/WMDE_Technical_Wishes/ReferencePreviews it seems like there have been conversations with some communities. @MBH: Could you please share specific examples which make the gadget on ruwiki better than the beta feature?

To clarify the situation as I understand it.

  1. Russian Wikipedia has ReferenceTooltips gadget enabled by default for all users, including anonymous users. We never had any significant problems with this gadget (and it had been enabled by default since 2012), one of its developers is active user on ru-wiki. We are fine with it and do not need a replacement.
  2. Reference previews feature was requested by German Wikipedia community and since then was rolled out as beta feature on several wikis, including Russian Wikipedia, which didn't request it to be enabled.
  3. Reference previews beta feature is enabled by default for new users on ru-wiki. This results in not one, but two popups appearing for new users, who are understandably confused by the situation.

We request to make Reference previews strictly opt-in feature in ru-wiki and do not enable it by default for our users. If that is not possible, disable it entirely for ru-wiki, as we already have this functionality and are satisfied with it.

Ruwiki uses the same Reference Tooltips gadget as enwiki. I've made the last big update to it in both wikis. The beta feature has several shortcomings some of which are critical to many users. I and other users have pointed some of them out on the project talk page.

I don't quite understand how come that the beta feature gets switched on for new users (does it mean that newly registered users get all beta features switched on?). I'm not even sure it's an intended behaviour. I support the request to disable such behaviour if it is confirmed.

MBH added a comment.Nov 24 2019, 5:19 PM

@MBH: Could you please share specific examples which make the gadget on ruwiki better than the beta feature?

@Aklapper Several reasons pointed on https://meta.wikimedia.org/wiki/Talk:WMDE_Technical_Wishes/ReferencePreviews#We_already_have_Reference_Tooltips (thanks Jack for this link). But I filed this task primarily not because of "gadget is better than beta feature", but because of 1) ruwiki has enabled gadget for all users and everyone likes it, 2) so, beta feature is not needed, 3) new users get enabled both gadget and beta feature, but unregistered users has only gadget, so, if we turn off the gadget instead of beta feature, unregistered users will lose reference previews at all.

stjn changed the task status from Stalled to Open.EditedDec 16 2019, 7:26 PM
stjn added a subscriber: stjn.

People should’ve removed ‘Stalled’ status. ReferencePreviews team enabled their beta feature to everyone without asking the community about anything, with a situation where two conflicting tools get shown to users with ReferencePreviews overflowing ReferenceTooltips. This is unacceptable in itself and needs to be fixed as soon as possible, without figuring out which version is better than the other.

This is, also, specifically what the devs wanted to avoid in T234204, so what exactly happened?

Jack_who_built_the_house renamed this task from Disable Reference Previews beta feature in ruwiki because all its users has enabled Reference Tooltips gadget by default to Disable Reference Previews beta feature in ruwiki because all its users have Reference Tooltips enabled gadget by default.Dec 16 2019, 7:27 PM
Jack_who_built_the_house updated the task description. (Show Details)

ReferencePreviews team enabled their beta feature to everyone without asking the community about anything

@stjn: No. There is a setting called "Automatically enable all new beta features"/"Автоматически включать все новые бета-функции" on https://ru.wikipedia.org/wiki/Служебная:Настройки#mw-prefsection-betafeatures . If you state that this setting was not activated by a user and the user still got the ReferencePreviews beta feature, then this would be a bug in BetaFeatures but not the fault of the ReferencePreviews team. Please see https://www.mediawiki.org/wiki/Bug_management/Phabricator_etiquette : "Criticize ideas, not people." Thanks.

I can confirm the stated behaviour. I've registered a new account after logging out from my account. The new account didn't get any of the beta features except ReferencePreviews.

@Aklapper Are you sure this is a bug, not a behaviour intended by the ReferencePreviews developers?

putnik added a subscriber: putnik.
putnik added a subscriber: awight.Dec 17 2019, 2:02 AM

Perhaps the problem is somehow related to the fact that the developers reused the existing preference: T236780. Given that article previews are enabled for all users, this could cause footnotes previews to be enabled for all users as well. @awight, can you comment on this?

Jack_who_built_the_house renamed this task from Disable Reference Previews beta feature in ruwiki because all its users have Reference Tooltips enabled gadget by default to Disable Reference Previews beta feature in ruwiki because all its users have Reference Tooltips gadget enabled by default.Dec 17 2019, 2:32 AM
awight triaged this task as High priority.Dec 17 2019, 8:24 AM
awight added a project: TCB-Team.

Thanks for the bug report! I'm increasing the priority—we've been under the impression that the conflict between the Reference Tooltips gadget and Reference Previews is acceptable for a short while, because users shouldn't see Reference Previews unless they've enabled the beta feature. However, this bug shows otherwise.

I don't have an answer about why our beta preference behaves differently from the others, but the file to look at is https://phabricator.wikimedia.org/diffusion/EPOP/browse/master/includes/PopupsHooks.php . I also don't have a suggestion for a quick workaround, the beta feature is supposed to protect us from exactly this sort of situation in which new users are inconvenienced, so unfortunately the only remedy would be to disable the beta feature entirely. I expect that we (WMDE Technical Wishes) can do something about the bug within the month, we'll give an update soon.

Restricted Application added a subscriber: Dereckson. · View Herald TranscriptDec 17 2019, 8:24 AM
awight edited projects, added BetaFeatures; removed Beta-Feature.
MBH added a comment.Dec 17 2019, 8:45 AM

@awight If you're a developer of Reference Previews, can you explain, why, in general, Reference Previews was created, if for many years exist fully functional, completed and useful gadget Reference Tooltips? Is it needed to reinvent the wheel?

@MBH Fair question. In a nutshell this seems to be the wiki product lifecycle. Experimental .js hacks become gadgets to make them easier to share among users. Gadgets might become an extension in order to make them more maintainable, performant, usable across wikis…

Here's the long story: https://de.wikipedia.org/wiki/Wikipedia:Technische_W%C3%BCnsche/Topw%C3%BCnsche/Vorschau_von_Einzelnachweisen_im_Artikeltext . We do understand that there's already a gadget and that some people will have a strong preference towards the gadget, it's fine to keep that question open of course, but probably better if we did that somewhere other than this task in order to keep energy focused on fixing the immediate problem.

I can confirmed the stated behaviour. I've registered a new account after logging out from my account. The new account didn't get any of the beta features except ReferencePreviews.

Uhm... Thanks a lot for making that explicitly clear, very appreciated! That behavior is... not good.

@Aklapper Are you sure this is a bug, not a behaviour intended by the ReferencePreviews developers?

putnik's answer above sounds like a good explanation, indeed.

Change 558464 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/Popups@master] Fix initial preferences for newly created user accounts

https://gerrit.wikimedia.org/r/558464

We've deployed a fix, please test again at your convenience. Expected behavior is that new users will not have Reference Previews enabled.

awight moved this task from Backlog to Doing on the Reference Previews board.Dec 18 2019, 12:53 PM
Arbnos added a subscriber: Arbnos.Dec 20 2019, 11:21 AM

We've deployed a fix, please test again at your convenience. Expected behavior is that new users will not have Reference Previews enabled.

Can anyone from the ruwiki community confirm?

@awight: Wondering if there is anything left to do in this task / if you want to resolve this?

Can anyone from the ruwiki community confirm?

I confirm: a newly registered account didn't get Reference Previews.

thiemowmde renamed this task from Disable Reference Previews beta feature in ruwiki because all its users have Reference Tooltips gadget enabled by default to New users get both ReferenceTooltips (gadget) and ReferencePreviews (Beta feature).Jan 5 2020, 4:04 PM

As far as I understand this was really just a mistake in the Reference Previews code. New users accidentally got the Beta feature enabled.

The discussion shows again why it's much better to just describe the issue (e.g. "new users see two popups"), instead of proposing a solution (here: requesting to kill a feature on a specific wiki). That made it exceptionally hard to understand the underlying issue. Thanks a lot for considering this in the future!

WMDE-Fisch closed this task as Resolved.Jan 6 2020, 9:50 AM
WMDE-Fisch claimed this task.

Can anyone from the ruwiki community confirm?

I confirm: a newly registered account didn't get Reference Previews.

So I consider the issue fixed now. Please re-open if you still run into that issue.