oversight-l subscriber list: "Visit Subscriber List" results in "You must supply a valid email address."
Closed, DeclinedPublic

Description

Author: mcdevitd

Description:
Currently, and for a little while now, the subscriber list for oversight-l has been unreachable, at least for non-listadmins. Putting in the correct email address and password at https://lists.wikimedia.org/mailman/listinfo/oversight-l and hitting "Visit Subscriber List" results in a page with the following error: "You must supply a valid email address." Multiple people report this problem, and the email addresses being supplied are identical to the ones subscribed, not actually invalid.


Version: unspecified
Severity: normal

bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz21928.
bzimport created this task.Via LegacyDec 23 2009, 5:40 AM
bzimport added a comment.Via ConduitDec 29 2009, 9:26 PM

fvassard wrote:

Looking into this.
More to come.

bzimport added a comment.Via ConduitMar 10 2010, 5:30 PM

fvassard wrote:

Could you tell me what happens if once you get the error message (after trying to login) you go to https://lists.wikimedia.org/mailman/roster/oversight-l
It seems to be working for me, albeit it is very weird.
Let me know!

bzimport added a comment.Via ConduitApr 4 2010, 6:25 AM

mcdevitd wrote:

(In reply to comment #2)

Could you tell me what happens if once you get the error message (after trying
to login) you go to https://lists.wikimedia.org/mailman/roster/oversight-l
It seems to be working for me, albeit it is very weird.
Let me know!

That does work, yes. So at least we have some way to see it from the non-administrator interface, thanks. Although, it lists one "private member not shown," whatever that means.

bzimport added a comment.Via ConduitJun 20 2011, 2:19 AM

bugs wrote:

Does this still happen or can we close the bug?

bzimport added a comment.Via ConduitJun 23 2011, 3:30 PM

bugs wrote:

I'm assuming the issue has fixed itself. Please re-open the bug if that's not true, and then we should try to look at whether or not anyone broke the HTML files.

bzimport added a comment.Via ConduitJul 9 2011, 2:56 AM

mcdevitd wrote:

This isn't resolved. I was told it was a simple error that would take a few minutes to fix... a year and a half ago. Nothing has changed.

bzimport added a comment.Via ConduitJul 11 2011, 4:46 PM

bugs wrote:

Do anyone tell you what the error was?

If you recently tested it and it still doesn't work, I think it might be related to the HTML files. Can you send me whatever the text in https://lists.wikimedia.org/mailman/edithtml/oversight-l/listinfo.html is?

bzimport added a comment.Via ConduitJul 11 2011, 8:31 PM

bugs wrote:

Philippe sent it to me and I can't find anything wrong in there. Well, there goes my idea. ;-)

bzimport added a comment.Via ConduitMay 2 2012, 12:19 AM

Thehelpfulonewiki wrote:

Just confirmed with an oversighter that the same error is occuring - http://www.wlug.org.nz/MailManNotes suggests a potential fix. http://mail.python.org/pipermail/mailman-users/2008-January/060018.html and http://mail.python.org/pipermail/mailman-users/2008-January/060026.html are a couple of posts on a thread back in 2008 describing the same problem. I'll send Daniel to this to have a look I think, as he's got a bit of experience with the apache config on mailman.

Dzahn added a comment.Via ConduitJun 12 2012, 7:19 AM

subscribed myself to be able to reproduce this, and i could.

i looked at this a bit and dumped the list config on shell, looking at the variables web_page_url and host_name as mentioned in http://www.debian-administration.org/articles/567 to fix with "withlist", host_name is lists.wikimedia.org.

ran withlist like this:

/withlist -l -r fix_url oversight-l -u lists.wikimedia.org
Importing fix_url...
Running fix_url.fix_url()...
Loading list oversight-l (locked)
Saving list
Finalizing

but it did not appear to fix/change it and i don't see a difference with "web_page_url" compared to all other lists.

hrmm.. Since there is a work-around which gave you the list you wanted (see above), the issue with an "unlisted private member" has disappeared meanwhile and the list is closed (note: it says it is closed and will not accept any mail), is it really needed? or how about just unsubscribing people from it if it really won't receive any new mails anymore?

bzimport added a comment.Via ConduitJun 12 2012, 7:46 AM

Thehelpfulonewiki wrote:

Hi Daniel - the list is actively used by oversighters themselves as far as I am aware for discussion. The list was previously used to handle actual overnighting requests, but this has now moved to OTRS, but it's possible that the email address or list info page is linked somewhere - that could be why the main page says that the list is no longer used, so people don't send OS requests to it.

Dzahn added a comment.Via ConduitJun 12 2012, 10:29 AM

ok. hmm. but existing links don't have to be broken, it can just sit there but does not need subscribers if it does not receive anything. It wouldn't even matter but it would be an easy way to resolve this ticket, since no subscribers = no need to keep trying to pull subscriber lists from it. (which even has the work around)

Snowolf added a comment.Via ConduitJun 12 2012, 12:40 PM

If it is still used, the mailing list should be renamed to something like oversight-en-wp-l or something that makes it clear that it's not a global list, or said discussion should take place in other avenues, such as functionaries-en

Dzahn added a comment.Via ConduitJun 12 2012, 1:22 PM

removed myself from list again as it indeed appears to be still in use.

JohnLewis added a comment.Via ConduitOct 7 2014, 4:23 PM

Assuming there has been no updates and the list is no longer used anymore; does this issue occur on any other lists?

If not; could we close this? :)

JohnLewis closed this task as "Declined".Via WebDec 20 2014, 12:03 AM
JohnLewis claimed this task.
Snowolf added a comment.Via WebDec 20 2014, 12:31 AM

I am no longer an enwiki oversighter, and no longer have access to the list, but I believe the list is still in active use.

Assuming there has been no updates and the list is no longer used anymore; does this issue occur on any other lists?

If not; could we close this? :)

Snowolf reopened this task as "Open".Via WebDec 31 2014, 9:14 PM
Snowolf set Security to None.

I've re-opened the task, as I am told the mailing list is still in active use. We need to figure out if the problem still exists tho.

Courcelles added a subscriber: Courcelles.Via WebDec 31 2014, 9:19 PM

Indeed, the mailing list is actively used for internal discussion, not for accepting oversight requests as it was in the past.

JohnLewis placed this task up for grabs.Via WebJan 6 2015, 6:14 PM

Removing myself as I can't exactly test this or really investigate.

Snowolf added a comment.Via WebFeb 4 2015, 3:07 AM

Courcelles, would you be able to test whether the problem is still occurring?

Krenair added a subscriber: Krenair.Via WebFeb 4 2015, 3:22 AM
Risker added a comment.Via WebFeb 4 2015, 3:45 AM

From https://lists.wikimedia.org/mailman/subscribe/oversight-l it is not possible to access the mailing list roster. One receives this message:

Oversight-l Subscription results
You must supply a valid email address.

This despite verifying that both the email address and the password were correct.

The details for the private roster: access is restricted to list members. (Note: not list admins).

In the great scheme of things, I am not certain how relevant it is; the person who filed the bug has not had access for years, none of the current members seem to be concerned about it (and have access through https://lists.wikimedia.org/mailman/roster/oversight-l ), and given its extremely low usage it seems like a waste of developer time and energy to have people keep working on this. At best, I would suggest updating the listinfo page and perhaps specifically linking to the "roster" instead of the "listinfo" might be worth a bit of time.

Risker (one of the list administrators)

JohnLewis added a comment.Via WebTue, Jul 7, 10:51 PM

what Risker said seems sane plus this will likely auto fix itself with an update anyway I guess (as most things do).

JohnLewis closed this task as "Declined".Via WebTue, Jul 7, 10:51 PM
JohnLewis claimed this task.
Meno25 removed a subscriber: Meno25.Via WebThu, Jul 9, 2:59 PM

Add Comment