Page MenuHomePhabricator

Follow up with DS to determine if silverpop contact's were likely privacy deletes
Closed, ResolvedPublic

Description

Silverpop contact_identifer = 388335560885 or 241528719644

(in civicrm_mailing_provider_data table)

Event Timeline

Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptNov 28 2019, 2:20 AM

So the issue here is when I do

SELECT * FROM civicrm_mailing_provider_data WHERE contact_identifier IN ('388335560885', '241528719644');

I find 2 email addresses that I cannot otherwise find in our DB. Here is the version with no PI in it:

SELECT contact_identifier, mailing_identifier, recipient_action_datetime, event_type, contact_id FROM civicrm_mailing_provider_data WHERE contact_identifier IN ('388335560885', '241528719644');
contact_identifiermailing_identifierrecipient_action_datetimeevent_typecontact_id
241528719644sp530028762016-12-25 11:00:58Sent
241528719644sp530028762016-12-25 11:14:28Open
241528719644sp530028782016-12-27 11:40:18Sent
241528719644sp552629282017-11-01 09:35:12Sent
241528719644sp605248002019-09-26 10:00:44Sent
241528719644sp605248002019-09-27 06:37:29Open
241528719644sp605248002019-09-27 07:14:12Opt Out
388335560885sp605248002019-09-26 10:00:51Sent
388335560885sp605549482019-09-30 19:01:25Sent
388335560885sp605549482019-10-01 01:44:03Clickstream
388335560885sp605549482019-10-01 01:44:12Clickstream
388335560885sp605549482019-10-01 01:44:12Opt Out

I can't find evidence of these email addresses in the table log_civicrm_email

select * FROM log_civicrm_email WHERE email IN ('##@gmail.com', '##@gmail.com');

Michael has confirmed these are not the subject of privacy requests.

I note they have no contact_id so perhaps they are RML & never made it to our DB. I'm

OK looking at the emails I see in the text of sp60524800 &

You are receiving this email at %%EMAIL%% because you asked us to send you a reminder on Wikipedia

that is also in sp60554948

We have not managed to retrieve sp55262928 & the ones earlier than that (either due to being too far back or Silverpop not sending)

I searched for the emails in SIlverpop & could not find them despite us having re-enabled RML fetching back in May but I think that part is a minor mystery - if they are RML contacts since removed from silverpop I think it's OK for them to be missing from civi without there being a big mystery

Ooh thanks for all the digging, Eileen. That copy is from an RML email for
sure!

Le mer. 15 janv. 2020 à 8:37 PM, Eileenmcnaughton <
no-reply@phabricator.wikimedia.org> a écrit :

Eileenmcnaughton moved this task from Doing to Deployed on the Fundraising
Sprint Autocorrect Astrology Ascendant board. View Task
https://phabricator.wikimedia.org/T239375
*TASK DETAIL*
https://phabricator.wikimedia.org/T239375
*WORKBOARD*
https://phabricator.wikimedia.org/project/board/4467/
*EMAIL PREFERENCES*
https://phabricator.wikimedia.org/settings/panel/emailpreferences/
*To: *Eileenmcnaughton
*Cc: *EYener, jkumalah, MeganHernandez_WMF, CCogdill_WMF, Aklapper,
MSuijkerbuijk_WMF, Eileenmcnaughton, jbolorinos-ctr, EBjune, DStrine

Eileenmcnaughton closed this task as Resolved.Tue, Jan 21, 8:32 PM