Page MenuHomePhabricator

🐛 Laika sending donation form without validation on ENTER-key
Closed, ResolvedPublic

Description

Current error behaviour:
When an input was clicked on https://spenden.wikimedia.de/
(e.g. payment selected, custom amount entered, payment option radio button clicked)
and immediately after it the ENTER-key is pressed, the form gets sent and leads to an empty page.

Desired behaviour:
Pressing the ENTER-key: ....

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 28 2019, 10:37 AM
CorinnaHillebrand_WMDE renamed this task from Laika sending donation form without validation on ENTER-key to 🐛 Laika sending donation form without validation on ENTER-key.Nov 28 2019, 10:40 AM

@Jan_Dittrich
could you give advice for the desired UX behaviour here?
What should happen on [1. enter/click input field, 2. press ENTER] ?
(Should it rather behave like a TAB press and switch to the next input field maybe?)

I cant reproduce this. When I go to spenden… click "5€" and press ENTER, it does nothing.

The right behavior should indeed be sending the form except when focus is in a multi-line-text field (which we have only for comments and to send a mail to support).

The correct behavior in would then be that the form gets send, but the user is pointed to the errors resulting from not having filled out the mandatory fields. This is currently done by scrolling to the first field which could not be validated.

To avoid the blank page we could prevent default on the enter key, but this is not solving "the actual problem" (whatever leads to forward to blank page) and breaks a standard behavior. So if the rates of the problem are high we could do it, but it would be an ugly end hopefully temporary fix.

kai.nissen closed this task as Resolved.Thu, Jan 9, 5:46 PM
kai.nissen claimed this task.