Page MenuHomePhabricator

WWT: Display WWT Link in Interface Language [small]
Closed, ResolvedPublicBUG REPORT

Description

As a WWT user, I want translations in my designated language to be accurately represented, so that I can understand the labels associated with the tool.

Background: Some of the WWT translations do not appear when you change your interface language. These include pt-br, roa-tara and zh-hant. I think it is because we are naming them in a way MediaWiki does not recognise. For example, I can get pt-br to work if I change it to pt-BR. Although, I tried with the other languages listed above, but could not get them to work.

Acceptance Criteria:

  • The WWT links should be represented in the interface language selected by user

Steps to reproduce problem:

  1. Install WWT
  2. Change your interface language to Brazilian Portuguese.
  3. Visit any article

E.g., you could just go directly to https://en.wikipedia.org/wiki/Mast_(sailing)?uselang=pt-br

Expected behavior: Under tools the "Who Wrote That?" link is translated to: "Quem escreveu isso?"
Observed behavior: The link is not translated

Visual Example:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 2 2019, 5:40 PM
ifried updated the task description. (Show Details)Jan 7 2020, 10:43 PM
ifried updated the task description. (Show Details)
ifried renamed this task from Some of the translations not recognised to WWT: Display WWT Link in Interface Language.Jan 7 2020, 10:46 PM
ifried renamed this task from WWT: Display WWT Link in Interface Language to WWT: Display WWT Link in Interface Language [small].Jan 8 2020, 12:34 AM
ifried moved this task from To Be Estimated/Discussed to Estimated on the Community-Tech board.
Restricted Application edited projects, added Community-Tech; removed Community-Tech (Kanban-Q3-2019-20). · View Herald TranscriptJan 8 2020, 1:13 AM
Samwilson claimed this task.Jan 8 2020, 2:25 AM
Samwilson added a subscriber: Samwilson.

A fix for this is to ensure we lowercase the language code. PR: https://github.com/wikimedia/WhoWroteThat/pull/132

@Samwilson I'm still not able to get this to work for roa-tara. Can for pt-br and zh-hant.

That being said, I don't see roa-tara in the list in https://en.wikipedia.org/wiki/Special:Preferences, although going to https://en.wikipedia.org/wiki/Mast_(sailing)?uselang=roa-tara I see the other parts of the MW UI are translated.

I'm not sure why it's not available in preferences; I assume because not all essential MediaWiki messages have been translated for it yet.

The ISO 639 language code for roa-tara is nap-x-tara, or rather I think that x-tara is an invention of MediaWiki itself (x- prefixes are custom ones). Anyway, I have done what I should have done to start with, and switched from pulling the IETF language code from the html element, and instead use the wgUserLanguage config value (which is ISO639)...

PR: https://github.com/wikimedia/WhoWroteThat/pull/137

This is ready for QA again.

The WWT translations now work for roa-tara (https://en.wikipedia.org/wiki/Mast_(sailing)?uselang=roa-tara).

Tested that it still works for zh-hant and pt-br and a couple of other languages (just in case of regressions).

Version: 60314b4d6d182e87d39fe2cff957b26819b6c2fa and 0.15.1.0 (from Chrome Store).

ifried closed this task as Resolved.Wed, Feb 5, 12:02 AM
ifried moved this task from Product sign-off to Done on the Community-Tech (Kanban-Q3-2019-20) board.
ifried added a subscriber: ifried.

I've tested this (see screenshot below), and it looks good. I'm marking it as Done.