Page MenuHomePhabricator

Improve MediaWiki:Dberrortext to link to a config-defined status page
Closed, DeclinedPublic

Description

Author: wikibug.5.starfury

Description:
If the german wikipedia (webserver?) can't connect to the database it brings the message "Konnte keine Verbindung
zur Datenbank auf $1 herstellen." (says "Could not establish connection to database on $1" or so.).
On the "noticed problems" page of the german section a user asks for a more descriptive message for not so
experienced users.
http://de.wikipedia.org/wiki/Wikipedia:Beobachtete_Fehler#Konnte_keine_Verbindung_zur_Datenbank_auf_.241_herstellen


Version: unspecified
Severity: enhancement
Platform: PC
URL: http://de.wikipedia.org

Details

Commits
Unknown Object (Diffusion Commit)
Reference
bz398

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 6:52 PM
bzimport set Reference to bz398.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Sep 6 2004, 10:48 AM
hashar added a comment.Dec 3 2005, 3:51 PM
  • Bug 3785 has been marked as a duplicate of this bug. ***
hashar added a comment.Dec 3 2005, 3:52 PM

From #3785:

Initial comment from Christopher Beland <beland@alum.mit.edu>, at 2005-10-23
21:04 UTC:

The past few days, I've occasionally been getting an error message that ends in
the diagnostic "(Can't contact the database server: )". It would be
considerably more helpful if this message contained the IP address or name of
the server it was attempting to contact, if not also the IP address or name of
the squid that produced the error. People seem to be reluctant to check all of
the servers just on the off chance there might still be a problem, especially
since the error is quite transient.

beland wrote:

Today, I got one error that said:


If reporting this error to the Wikimedia System Administrators, please include
the following details:
Request: GET http://en.wikipedia.org/wiki/Category:Broadcasting, from 0.0.0.0
via srv8.wikimedia.org (squid/2.5.STABLE12) to en.wikipedia.org ([unknown])
Error: ERR_CANNOT_FORWARD, errno (104) Connection reset by peer at Sat, 03 Dec
2005 23:49:16 GMT


And another that said:


ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: http://en.wikipedia.org/wiki/Category:Memetics

The following error was encountered:

  • Connection Failed

The system returned:

(110) Connection timed out

The remote host or network may be down. Please try the request again.

Your cache administrator is wikidown@bomis.com.
Generated Sat, 03 Dec 2005 23:50:06 GMT by srv7.wikimedia.org
(squid/2.5.STABLE12)


If the IP address of the MySQL server which is down is known, it should be
included in these messages. -B.

happy.melon.wiki wrote:

LATER per Brion at bug18824c3.

happy.melon.wiki wrote:

*** Bug 18824 has been marked as a duplicate of this bug. ***

demon added a comment.Jul 24 2009, 2:15 PM

Better summary than "Mediawiki:"

happy.melon.wiki wrote:

I think I got distracted... :D

What I was *trying* to write was that this only applies to [[MediaWiki:dberrortext]]...

brion added a comment.Nov 29 2011, 8:18 PM

Is this even necessary? Would simply improving the default message (especially if it can link to a config-defined status page) help here?

beland wrote:

Makes sense to me, if the default message both contains useful diagnostic information and an introductory message friendly to non-technical users.

[Reopening "RESOLVED LATER" as lowest priority.]

Strings are around "# General errors" in https://gerrit.wikimedia.org/r/gitweb?p=mediawiki/core.git;a=blob;f=languages/messages/MessagesEn.php#l973

sucheta.ghoshal wrote:

Is this bug really relevant anymore? Because I can not really find the message that had been posted at first, maybe it has changed or something?

Key is the same: https://translatewiki.net/wiki/MediaWiki:Dberrortext/en

A database query syntax error has occurred.
This may indicate a bug in the software.
The last attempted database query was:
<blockquote><code>$1</code></blockquote>
from within function "<code>$2</code>".
Database returned error "<samp>$3: $4</samp>".

sucheta.ghoshal wrote:

So, the German message says the same thing, I suppose ( Pardon me, if I am too wrong. I don't really know German). If it does not have any problem with the message - maybe we should close this bug?

The message is always the same and the same still applies...

Brion's bug 18824 comment 3

I'm pretty sure we deliberately don't use the site-customized messages in the
DB error since by definition if our DB access is broken it may not be safe to
pull from the DB. You don't necessarily know what the problem was or what
further attempts to access the backend might cause. Probably not worth the
effort of poking at it, but we can LATER it for prettification.

epriestley closed this task as Resolved by committing Unknown Object (Diffusion Commit).Mar 4 2015, 8:19 AM
epriestley added a commit: Unknown Object (Diffusion Commit).
demon reopened this task as Open.Mar 4 2015, 8:37 AM
jrbs added a subscriber: jrbs.

Looking at the task description, what is the reason for having "a config-defined status page"?
Also, it looks like https://translatewiki.net/wiki/MediaWiki:Dberrortext/en has been improved in the meantime to state which function has been called and which error message was triggered, so is the request for "a more descriptive message for not so experienced users" now covered? If not, what exactly is expected here?

demon removed a subscriber: demon.Dec 15 2016, 10:30 PM
Aklapper closed this task as Declined.Apr 20 2017, 4:21 PM

Looking at the task description, what is the reason for having "a config-defined status page"?
Also, it looks like https://translatewiki.net/wiki/MediaWiki:Dberrortext/en has been improved in the meantime to state which function has been called and which error message was triggered, so is the request for "a more descriptive message for not so experienced users" now covered? If not, what exactly is expected here?

Declining as no answer was given. If this is still an issue, please reopen this task and clarify the problems and expectations nowadays.