Page MenuHomePhabricator

Introduce a temporary banner on Special:Block to inform users about upcoming partial blocks deploy
Closed, ResolvedPublic2 Estimated Story Points

Description

Goal

We want to inform users on all our projects where Partial blocks isn't deployed yet (except enwiki which wants to hold an RfC) to inform them about the upcoming deployment.

Acceptance criteria:

  • All text will be translatable.
  • Banner will only be visible on Special:Block on production wikis where Partial blocks isn't already deployed. Also it will not be displayed on enwiki, which will conduct its own RfC.
  • Banner should ideally go up this or next week (week of Dec 16) and will stay up until after the deployment in January.
  • Post-deployment of partial blocks, we will keep the banner up for another 2 weeks to let users know and learn about the changes they are seeing.
  • The banner should be taken down on Jan 21.

Details

ProjectBranchLines +/-Subject
operations/mediawiki-configmaster+0 -31
mediawiki/extensions/WikimediaMessageswmf/1.35.0-wmf.16+2 -72
mediawiki/extensions/WikimediaMessageswmf/1.35.0-wmf.15+2 -72
mediawiki/extensions/WikimediaMessagesmaster+2 -72
mediawiki/extensions/WikimediaMessageswmf/1.34.0-wmf.16+2 -72
mediawiki/extensions/WikimediaMessageswmf/1.34.0-wmf.15+2 -72
operations/mediawiki-configmaster+0 -2
operations/mediawiki-configmaster+27 -0
mediawiki/extensions/WikimediaMessagesmaster+1 -1
mediawiki/extensions/WikimediaMessagesmaster+4 -3
mediawiki/extensions/WikimediaMessagesmaster+1 -1
mediawiki/extensions/WikimediaMessageswmf/1.35.0-wmf.11+1 -1
operations/mediawiki-configmaster+6 -0
mediawiki/extensions/WikimediaMessagesmaster+74 -4
Show related patches Customize query in gerrit

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added subscribers: MGChecker, Aklapper. · View Herald TranscriptDec 10 2019, 12:01 AM

Ping @SPoore - added this ticket for estimation tomorrow. I made a call to delay the deployment until January. It's possible that major bugs that might show up while we are all away for the break and deploys aren't allowed. This also gives us more time to have the message translated.

Just for your information, we are planning to hold a RFC on Commons for partial block deployment. We imported the RFC page from enwiki to Commons and are modifying/developing the draft for Commons. It can be seen at https://commons.wikimedia.org/wiki/Commons:Requests_for_comment/Partial_blocks .

Just for your information, we are planning to hold a RFC on Commons for partial block deployment. We imported the RFC page from enwiki to Commons and are modifying/developing the draft for Commons. It can be seen at https://commons.wikimedia.org/wiki/Commons:Requests_for_comment/Partial_blocks .

Thanks @Masumrezarock100. Do you know when the RfC is going to be voted on?

Masumrezarock100 added a comment.EditedDec 10 2019, 1:01 AM

Just for your information, we are planning to hold a RFC on Commons for partial block deployment. We imported the RFC page from enwiki to Commons and are modifying/developing the draft for Commons. It can be seen at https://commons.wikimedia.org/wiki/Commons:Requests_for_comment/Partial_blocks .

Thanks @Masumrezarock100. Do you know when the RfC is going to be voted on?

Good news. We just finished writing and proofreading the proposal. Voting phase has finally started!

Niharika set the point value for this task to 2.Dec 10 2019, 7:15 PM

Good news. We just finished writing and proofreading the proposal. Voting phase has finally started!

Excellent! Let me know if I can answer any questions.

Niharika raised the priority of this task from Medium to High.Dec 10 2019, 8:14 PM
dmaza claimed this task.Dec 10 2019, 8:53 PM

Change 556519 had a related patch set uploaded (by Dmaza; owner: Dmaza):
[mediawiki/extensions/WikimediaMessages@master] Add Partial Block banner to Special:Block

https://gerrit.wikimedia.org/r/556519

Change 556519 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Add Partial Block banner to Special:Block

https://gerrit.wikimedia.org/r/556519

@dmaza Do we need to do something special to trigger translations? I can poke the Translators-l mailing list but want to make sure the message is ready to be translated on translatewikinet.

dom_walden added a subscriber: dom_walden.

I could only test this on my local versions, as I cannot change the settings on beta.

Here's what I see on Special:Block for different combinations of settings:

$wgEnablePartialBlocks$wgWikimediaMessagesPartialBlockBannerBanner
FalseFalseNot shown
TrueTrueNot shown
FalseTrueShown
TrueFalseNot shown

The button's link is https://www.mediawiki.org/wiki/Special:MyLanguage/Help:Blocking_users.

There are no translations to test yet. I have made a todo for myself to test these as soon as they are up.

Version: MediaWiki 1.35.0-alpha (46f6a9e) 18:57, 12 December 2019; WikimediaMessages – (a580706) 18:24, 12 December 2019

There are no translations to test yet. I have made a todo for myself to test these as soon as they are up.

I can confirm the translation looks ok in Spanish (on my local server).

Thanks Dom! I have sent out a call for translations. Hopefully we'll get some more before Thursday.

Change 559132 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[operations/mediawiki-config@master] Enable banner on Special:Block for selected wikis

https://gerrit.wikimedia.org/r/559132

Change 559132 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable banner on Special:Block for selected wikis

https://gerrit.wikimedia.org/r/559132

Change 559180 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/extensions/WikimediaMessages@master] Remove messagebox class from partial block banner

https://gerrit.wikimedia.org/r/559180

Change 559184 had a related patch set uploaded (by Niharika29; owner: Tchanders):
[mediawiki/extensions/WikimediaMessages@wmf/1.35.0-wmf.11] Remove messagebox class from partial block banner

https://gerrit.wikimedia.org/r/559184

Change 559184 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@wmf/1.35.0-wmf.11] Remove messagebox class from partial block banner

https://gerrit.wikimedia.org/r/559184

Mentioned in SAL (#wikimedia-operations) [2019-12-18T19:59:04Z] <niharika29@deploy1001> Synchronized php-1.35.0-wmf.11/extensions/WikimediaMessages/includes/WikimediaMessagesHooks.php: Remove messagebox class from partial block banner - T240300 (duration: 01m 02s)

Change 559180 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Remove messagebox class from partial block banner

https://gerrit.wikimedia.org/r/559180

Mentioned in SAL (#wikimedia-operations) [2019-12-18T20:04:41Z] <niharika29@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Enable banner on Special:Block for selected wikis - T240300 (duration: 01m 01s)

Niharika updated the task description. (Show Details)Jan 6 2020, 9:31 PM

Change 562373 had a related patch set uploaded (by Dbarratt; owner: Dbarratt):
[mediawiki/extensions/WikimediaMessages@master] Update Partial Block notice for post-deployment

https://gerrit.wikimedia.org/r/562373

Change 562373 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Update Partial Block notice for post-deployment

https://gerrit.wikimedia.org/r/562373

Change 562391 had a related patch set uploaded (by Dbarratt; owner: Dbarratt):
[mediawiki/extensions/WikimediaMessages@master] Display partial block notice to wikis who have partial blocks enabled

https://gerrit.wikimedia.org/r/562391

Change 562531 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[operations/mediawiki-config@master] Disable banner on Special:Block for partial blocks early-adopters

https://gerrit.wikimedia.org/r/562531

Change 562391 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Display partial block notice to wikis who have partial blocks enabled

https://gerrit.wikimedia.org/r/562391

Change 562531 merged by jenkins-bot:
[operations/mediawiki-config@master] Disable banner on Special:Block for partial blocks early-adopters

https://gerrit.wikimedia.org/r/562531

Mentioned in SAL (#wikimedia-operations) [2020-01-07T16:43:23Z] <jforrester@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Disable banner on Special:Block for partial blocks early-adopter wikis T240300 (duration: 00m 57s)

Change 564121 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[operations/mediawiki-config@master] Enable banner for wikis that recently opted in to partial blocks

https://gerrit.wikimedia.org/r/564121

@Urbanecm had some questions on gerrit about the timing of enabling this banner on enwiki and commons. @SPoore and @Niharika - would you be able to advise? Thanks.

Change 564121 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable banner for wikis that recently opted in to partial blocks

https://gerrit.wikimedia.org/r/564121

Mentioned in SAL (#wikimedia-operations) [2020-01-15T19:54:20Z] <jforrester@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Enable banner for wikis that recently opted in to partial blocks T240300 T242570 T242569 (duration: 01m 05s)

@Urbanecm had some questions on gerrit about the timing of enabling this banner on enwiki and commons. @SPoore and @Niharika - would you be able to advise? Thanks.

Sorry for noticing this late. @Urbanecm Do you still have questions for us?

No, I believe @Tchanders answered everything.

Follow up on https://meta.wikimedia.org/wiki/Talk:Community_health_initiative/Partial_blocks#specialblock-partialblock-banner
This is appearing on enwiki, we have local discussions and support for this - and are still actually working on our policies for it, so would probably be better to direct our admins to our local discussion.

@Xaosflux Thanks for linking to the conversation. The task description says the banner is due to be removed from all wikis today - is that still the case @Niharika, @SPoore?

Change 566301 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/extensions/WikimediaMessages@master] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566301

Change 566302 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[operations/mediawiki-config@master] Remove partial blocks banner from all wikis

https://gerrit.wikimedia.org/r/566302

Change 566301 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566301

Change 566574 had a related patch set uploaded (by Dbarratt; owner: Tchanders):
[mediawiki/extensions/WikimediaMessages@master] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566574

Change 566575 had a related patch set uploaded (by Dbarratt; owner: Tchanders):
[mediawiki/extensions/WikimediaMessages@master] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566575

Change 566574 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@wmf/1.34.0-wmf.15] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566574

Change 566575 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@wmf/1.34.0-wmf.16] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566575

Change 566577 had a related patch set uploaded (by Catrope; owner: Tchanders):
[mediawiki/extensions/WikimediaMessages@wmf/1.35.0-wmf.15] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566577

Change 566578 had a related patch set uploaded (by Catrope; owner: Tchanders):
[mediawiki/extensions/WikimediaMessages@wmf/1.35.0-wmf.16] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566578

Change 566577 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@wmf/1.35.0-wmf.15] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566577

Change 566578 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@wmf/1.35.0-wmf.16] Remove temporary partial block banner, added in 01fcc09234

https://gerrit.wikimedia.org/r/566578

Mentioned in SAL (#wikimedia-operations) [2020-01-22T19:45:28Z] <catrope@deploy1001> Synchronized php-1.35.0-wmf.15/extensions/WikimediaMessages/: Remove temporary partial block banner (T240300) (duration: 01m 10s)

Mentioned in SAL (#wikimedia-operations) [2020-01-22T19:46:35Z] <catrope@deploy1001> Synchronized php-1.35.0-wmf.16/extensions/WikimediaMessages/: Remove temporary partial block banner (T240300) (duration: 01m 06s)

Niharika closed this task as Resolved.Jan 22 2020, 9:22 PM

Change 566302 merged by jenkins-bot:
[operations/mediawiki-config@master] Remove unused config for partial blocks banner

https://gerrit.wikimedia.org/r/566302

Mentioned in SAL (#wikimedia-operations) [2020-01-23T18:40:04Z] <jforrester@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Stop setting wgWikimediaMessagesPartialBlockBanner, never read T240300 (duration: 01m 06s)