Page MenuHomePhabricator

Upload Wizard failing on multiple uploads on Commons: "Unknown error. "$1"." / TypeError: upload.ui.clearIndicator is not a function
Closed, ResolvedPublic

Description

All day been trying to upload groups of files sharing the same info. Sits there for ages with progress indicators whirling, then stops with red ! and either connectivity OR unknown error. Even uploading a single file stops at about 95% then either fails or completes, but it is impacting our workflow quite seriously.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 13 2019, 6:47 PM
Aklapper changed the task status from Open to Stalled.Dec 13 2019, 8:28 PM
Aklapper removed Rodhullandemu as the assignee of this task.
Aklapper added a project: UploadWizard.

@Rodhullandemu: Assuming this task is about UploadWizard, hence adding project tag so others can find this task when searching for tasks under that project. Also resetting assignee as I assume you don't plan to work on fixing this yourself.

All day been trying to upload groups of files sharing the same info.

Can you please elaborate by following https://www.mediawiki.org/wiki/How_to_report_a_bug and provide a clear list of steps to reproduce that do not leave room for interpretation? Thanks in advance!

GPSLeo added a subscriber: GPSLeo.Dec 13 2019, 8:58 PM

As I have the same problem here some information I can provide.

I upload some files with the Wizard, most files get uploaded very well.

If the the text in the Wizard says file is "in queue" the request looks like:

action	upload
format	json
stash	1
checkstatus	true
filekey	17421kg5v99k.9iqmg0.6579311.jpg
errorformat	html
errorlang	de
errorsuselocal	1
formatversion	2
token	2ce61c37bdc203c83e4d32b7211823765df3ee45+\

And the response is:

{"upload":
{"result":"Poll","stage":"queued"}}

After many of these requests and responses the text changes to "Unknown error. "$1"." and there are no more requests.

Hitting the "try uploading of these files again" creates a JavaScript error:

TypeError: upload.ui.clearIndicator is not a function
load.php:73:333

Thanks! "Unknown error. "$1"." is also mentioned in T240653: Upload wizard: error message 'unknown error: "$1" ' and upload does fail. which might be the same issue.
TypeError: upload.ui.clearIndicator is not a function is also mentioned in T220472: UploadWizard “Retry failed uploads” throws upload.ui.clearIndicator is not a function.

Aklapper renamed this task from Upload Wizard failing on multiple uploads on Commons to Upload Wizard failing on multiple uploads on Commons: "Unknown error. "$1"." / TypeError: upload.ui.clearIndicator is not a function.Dec 13 2019, 9:20 PM
Aklapper changed the task status from Stalled to Open.

Based on some (very) brief git archaeology, @Esanders made commit eb978f9fd3450b11e76bce6c2612b831f7e52960 which removed the clearIndicator method, which suggests he may be best able to remove the only remaining call to it when he gets a chance (and replace it with something analogous, if necessary).

I believe, however, that may be a separate bug from the "unknown error: $1" issue - we might want to come back and investigate after the clearIndicator bug is fixed.

File:Global Climate Strike Bremen 2019-12-13 01.jpg <- file was uploaded, but publishing took an eternality and then showed "unknown server error"

I have uploaded a few empty files and than used stashedupload.js to upload the real files. for one file:
400 sec upload
4400 sec assembling
4000 sec publishing

same for the other files

may be wizard is running into time out?

given ApiUpload.php (which UploadWizard seems to call) seems to be queue dependant (cf https://github.com/wikimedia/mediawiki/blob/master/includes/api/ApiUpload.php#L811), i'd blame T240518.

Wargo added a subscriber: Wargo.Dec 17 2019, 12:52 PM

Are you still experiencing this issue?

Aklapper closed this task as Resolved.Feb 8 2020, 1:50 PM

Are you still experiencing this issue?

No reply, plus T240518 got resolved, hence closing this task. Please set the status of this task back to "Open" via the Add Action...Change Status dropdown if this still happens.