Page MenuHomePhabricator

WWT: Adjust Username Appearance [high priority] [medium]
Closed, ResolvedPublic

Description

As a WWT user, I want to adjust the appearance of usernames to be from MW api, so that the data can be more reliable.

Acceptance Criteria:

  • Remove the display of the username/IP address from the information bar in WWT
  • Keep the highlighting feature in WWT (it should not be removed)
  • Update the display of username/IP address in the information details pop-up, so that it's pulling data from the MW API
  • Ensure that first the loading animation appears and then all of the data together (i.e., the percentage of page written by user loads along with other data)
  • We should have loading animation display at least 2 lines at the top and one at the bottom

Event Timeline

ifried created this task.Dec 13 2019, 7:40 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 13 2019, 7:40 PM
ifried updated the task description. (Show Details)Dec 16 2019, 6:40 PM
ifried renamed this task from WWT: Adjust Username Appearance [high priority] to WWT: Adjust Username Appearance [high priority/tentative medium].Dec 16 2019, 6:43 PM
ifried updated the task description. (Show Details)
ifried updated the task description. (Show Details)Dec 16 2019, 10:38 PM
ifried renamed this task from WWT: Adjust Username Appearance [high priority/tentative medium] to WWT: Adjust Username Appearance [high priority] [medium].Dec 16 2019, 10:40 PM
MusikAnimal triaged this task as High priority.Dec 17 2019, 5:47 PM
dom_walden added a subscriber: dom_walden.

@MusikAnimal FYI, I found bug T241062 while testing this change. The bug existed before your change, although the impact of it is greater now.

Acceptance Criteria:

  • Remove the display of the username/IP address from the information bar in WWT

Done.

  • Keep the highlighting feature in WWT (it should not be removed)

Sure.

  • Update the display of username/IP address in the information details pop-up, so that it's pulling data from the MW API

I ran a Selenium script which parsed the HTML of the revision detail popup for each token on 5 random pages each from enwiki, eswiki, dewiki, euwiki and trwiki.

The script compares the username in the revision popup with what is returned by both the WhoColor API and MW API. It detected no discrepancies.

Nor have I seen any discrepancies myself while testing it.

Moreover, the issue in T234448 appears to have been addressed in this bug. For privacy reasons, I will include examples in that bug.

  • Ensure that first the loading animation appears and then all of the data together (i.e., the percentage of page written by user loads along with other data)

Done.

Bug T241062 raised (but not caused by this task).

  • We should have loading animation display at least 2 lines at the top and one at the bottom

The loading animation is 3 lines.

It looks like this:

ifried closed this task as Resolved.Jan 2 2020, 7:21 PM
ifried moved this task from Product sign-off to Done on the Community-Tech (Kanban-Q2-2019-20) board.

I have tested this, and we're no longer seeing the username/IP address in the information bar (as per the requirements). Furthermore, the tool is working properly with the recent changes, with the username and IP address data coming from the MW API. For these reasons, I'm marking this work as Done.