Page MenuHomePhabricator

Enabling maps rendering and images in Wikibase
Closed, ResolvedPublic

Description

Hi,

I'm not sure if I didn't find the documentation or if this is not possible. I would like to enable rendering of images and maps in a Wikibase instance. Reading this task T184933 I tried by setting

$wgWBRepoSettings['useKartographerGlobeCoordinateFormatter'] = true;

but this didn't work out. For images I have no clue.

I would also vote for putting this as default configuration in the wikibase-docker ; )

Thank you
D063520

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Ok, this works out! Thank you!

And what about images from Wikidata Commons?

I believe that is currently done using a gadget on Wikidata.org.
We will work to include this in Wikibase as a default feature in 2020.

Addshore added a subscriber: Addshore.

You mean showing the image previews? That is not a gadget for all I know but Wikibase code.

Yes, I mean the image previews

Addshore claimed this task.

The image preview formatting is done by CommonsInlineImageFormatter which should be enabled by default for all wikibases as far as I can see.
This was done in T224189 and https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/Wikibase/+/528497/
Which version of Wikibase are you using?
It looks like right now this feature is only on master (not in the releases) so if your using a release you won't yet see it.

Hi,

could you indicate the process to upgrade the current version wikibase/wikibase:1.33-bundle in the docker-compose setting to the master branch. This way I can try out the new feature. I read this:

https://addshore.com/2019/01/wikibase-docker-mediawiki-wikibase-update/

but some steps are missing I think?

Thank you
D063520

Hi,

I just installed 1.35 but the images do not seam to be rendered. For example this item:

https://linkedopendata.eu/wiki/Item:Q141

the property image. I'm not sure where the bug is, but what I find strange is that it does not seams like he is trying to render the image, he treats it as a url ...

Salut
D063520

PS: we reverted the online version to 1_34. But the problem appeared also with 1_35

Hi,

I was able to successfully deploy 1.35. The problem with the image remains. See for example:

https://linkedopendata.eu/wiki/Item:Q235272

Are there any news on this issue? I feel that he is not even trying to render the image, maybe it is more a matter of missing configuration?!

Thank you : )
D063520

I see the map render there, but it does look like something else is missing loading?

image.png (624×802 px, 49 KB)

It could be that after your update this page was still cached, and the page has since purged.

image.png (50×1 px, 11 KB)

The URL being used is https://a.tile.openstreetmap.org//v4/marker/pin-l-marker+0050d0.png

If that persists it could perhaps do with a ticket filed for it

DD063520 reopened this task as Open.EditedJan 12 2021, 8:09 PM

No wait ... the problem is with the image, not the map, for the map I have a Kartographer issue! But you said the image would render, but it does not ....

PS see you message from the 14 Jan

Aaah, so the only problem is the pin image on the map? not the map itself? :)

No the problem are the images from wikimedia commons! They are not rendered ....

Aaah right, sorry I missed the and images in the title!

No problem, would be nice if you could look at that though : )

Right, it looks like the CommonsInlineImageFormatter which is used to display this image does not work on Wikibases that are not Wikidata.

I suspect but can not confirm that this is probably due to this code not working with instant commons

image.png (273×869 px, 32 KB)

@DD063520 could we perhaps close this phabricator task and open one just for the image issue (to make things easier to follow)?

DD063520 closed this task as Resolved.EditedJan 12 2021, 8:24 PM

thank you and sure I will
Moving the issue with the image to T271860