Page MenuHomePhabricator

Sometimes Q77104211 shows up in sparql query as having a wrong value for P2397, however item is deleted since December 3rd 2019
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

Run the query my bot runs twice a day: https://w.wiki/DxD

Actual Results:

Sometimes Q77104211 gets returned (last time reproduced was around 12AM UTC 16-12-2019)

Expected Results:

Never return Q77104211 (as item has been deleted on December 3rd 2019)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Also reproduced December 18th and December 19th 12AM UTC.

Have been able to reproduce it (or better my bot):
18-12 00:00 UTC / 19-12 00:00 UTC / 21-12 12:00 UTC / 23-12 00:00 UTC / 26-12 12:00 UTC / 27-12 12:00 UTC / 28-12 00:00 UTC / 28-12 12:00 UTC / 31-12 12:00 UTC / 01-01 12:00 UTC / 02-01 00:00 UTC
So it seems there is some datapolution on 1 or a few database servers that provide the triples for the Wikidata Query Service. And it doesn't look like it will be solved automatically.

A full reimport is in progress and should solve this issue once completed (or if it does not, then we'll need to dig deeper). Reimport has started last week and is likely to run for another week. It then needs to be propagated to all servers...

A full reimport is in progress and should solve this issue once completed (or if it does not, then we'll need to dig deeper). Reimport has started last week and is likely to run for another week. It then needs to be propagated to all servers...

Thanks for the update. I'll check if it still occurs after the reimport is finished.

Full reimport is in progress. By the look of it, it will still take around a week to catch up on lag on wdqs1010 before we can copy the data over to other servers.

Gehel claimed this task.

This should be fixed by latest data reload (T252068). Feelf ree to reopen if that's not the case.