Page MenuHomePhabricator

Unable to publish changes to an outdated beta.wmflabs.org talk page
Closed, ResolvedPublic

Description

As reported here [1], you are not able to edit a previous version of a beta.wmflabs.org talk page.

Expected behavior

  1. Go to a prior version of the talk page you are viewing (e.g. https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Talk:Cats&oldid=407990)
  2. Click "Edit source"
  3. Make changes
  4. Click "Publish changes..."
  5. ✅ Changes successfully published to page

Actual behavior

  1. Go to a prior version of the talk page you are viewing (e.g. https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Talk:Cats&oldid=407990)
  2. Click "Edit source"
  3. ⚠️Unable to make any changes to the page

  1. https://www.mediawiki.org/w/index.php?title=Topic:Vcwvt3bq03o5gv8h&topic_showPostId=vd8593amh18c3myw#flow-post-vd8593amh18c3myw

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 23 2019, 10:46 PM
DannyS712 added a subscriber: DannyS712.EditedDec 24 2019, 1:22 AM

So I took a look - https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Talk:Cats&diff=408270&oldid=408269
The specific text input element to type in:

<textarea class="ve-init-mw-tempWikitextEditorWidget mw-editfont-monospace mw-content-ltr" lang="en" dir="ltr" style="height: 3209px;" readonly=""></textarea>

That readonly flag is what is preventing editing.
I found a readonly tag added by VisualEditor in https://gerrit.wikimedia.org/g/mediawiki/extensions/VisualEditor/+/f4fb6fc3562780d8ca711507300306c3fdec125d/modules/ve-mw/preinit/ve.init.mw.DesktopArticleTarget.init.js#155, could that be causing it?

Change 560855 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/DiscussionTools@master] Fix crash when opening VisualEditor NWE while DiscussionTools enabled

https://gerrit.wikimedia.org/r/560855

The problem is caused by DiscussionTools trying to process the edit notices inside VisualEditor NWE as if they were page content, and crashing because they're not (and bringing VisualEditor down as well). It will only occur if the page has edit notices (or if you edit while not logged in, in which case we always display an edit notice about this).

Change 560855 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Fix crash when opening VisualEditor NWE while DiscussionTools enabled

https://gerrit.wikimedia.org/r/560855

matmarex claimed this task.Jan 9 2020, 11:08 PM
matmarex edited projects, added VisualEditor (Current work); removed VisualEditor.
matmarex moved this task from Incoming to QA on the VisualEditor (Current work) board.

Note that we also removed NWE as default on the Beta Cluster (https://gerrit.wikimedia.org/r/c/operations/mediawiki-config/+/561649), so to QA this, you'll have to log in and enable it in your preferences.

Ryasmeen edited projects, added Verified; removed Editing QA.Jan 16 2020, 9:23 PM
Ryasmeen moved this task from QA to Product owner review on the VisualEditor (Current work) board.
ppelberg closed this task as Resolved.Jan 21 2020, 1:51 AM