Page MenuHomePhabricator

Investigate why importDump.php < xmlfile.xml complains that BackupReader::handleRevision is private
Closed, ResolvedPublic

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 24 2019, 6:03 PM
Reedy reopened this task as Open.Dec 24 2019, 9:23 PM

Change 560547 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@master] Mark some more BackupReader functions public

https://gerrit.wikimedia.org/r/560547

Reedy added a subscriber: Reedy.Dec 24 2019, 9:29 PM

Change 560547 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@master] Mark some more BackupReader functions public

https://gerrit.wikimedia.org/r/560547

Caused by https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/542553/

I noticed two other functions that were called as callbacks in the same part of the code would likely similarly fail - marked as public

Umherirrender closed this task as Resolved.Dec 24 2019, 11:48 PM
Umherirrender assigned this task to Reedy.
Umherirrender triaged this task as Medium priority.

Change 560547 merged by jenkins-bot:
[mediawiki/core@master] Mark some more BackupReader functions public

https://gerrit.wikimedia.org/r/560547