Page MenuHomePhabricator

translate contents issue on tablet
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:

  1. take a tablet (mine is Samsung Galaxy Tab A)
  2. in chrome open URL => https://m.mediawiki.org/wiki/Template:PD_Help_Page/fr : A french page displays (mine was 'modified 20 days ago by Mainframe98' )
  3. hit link 'translated version'
  4. screenshot 1 opens
  5. select a language in the list 'Traduire en' and observe screenshot 2

Actual Results:

  • Point 4 : you have both on left and right message columns French messages (.... strange?)
  • Point 5: languages at local scale include 'Je fais' between englisg and interlingua

Expected Results:

  • Point 4 : when translating a sub page (here /fr) the left column should display messages of the root EN page and not a previous version of the translated messages.
  • Point 5: Ido is a language name and although it means 'Je fais' in french, it has not to be translated (keep ABBA's hit name!)

Event Timeline

Wladek92 created this task.Tue, Dec 24, 7:31 PM
Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptTue, Dec 24, 7:31 PM
Wladek92 removed I18n as the assignee of this task.Tue, Dec 24, 7:32 PM
Wladek92 added a project: I18n.
Wladek92 added a subscriber: I18n.
Zoranzoki21 removed a subscriber: I18n.

Isn't this a bad translation caused by Google Chrome automatic translator? I'm seeing a Google Chrome translation toolbar at the bottom of the images, saying it translated the page from English to French

I agree with you that on the tablette, there is a 'toolbar' at the bottom of the Chrome window. I dont when it comes from. Any 'normal' page has not this tool bar. It appears always when I click on the link 'Translate this page' calling the page with two columns for translation. But the problem is that 'Je fais' of box 'Search for a language' is opened when you click on the link 'Taduire en XXXXX' that means from Mediawiki CSS and NOT from the toolbar (which has its own list opened using the 3 vertical dots).

Wladek92 added a comment.EditedWed, Dec 25, 12:36 AM

POINT 4 concerning the 2 french columns: solved, the 'toolbar' Ciencia spoke of is a magic selector of Chrome you must be aware. If it is set on 'français' chrome translate automatically MediaWiki english contents into french so you see two french columns which leads to nonsense for the translator. Now if you select 'english' then left column remains in english and the right one in french which is consistent with desktop behaviour.

POINT 5: still open

Aklapper renamed this task from translate contents issue on tablette to translate contents issue on tablet.Wed, Dec 25, 11:31 AM
Aklapper updated the task description. (Show Details)
Aklapper closed this task as Invalid.EditedWed, Dec 25, 11:34 AM

Hi, feel free to disable automatic Google Translate in your browser if Google Translate interferes and replaces ("translates") content on pages. If this problem still happens without using Google Translate, then please reopen this task. Closing this task as there is nothing that can be done, as we do not maintain Google Translate.

For future reference, please always include web browser information and web browser version information in tasks.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptWed, Dec 25, 11:34 AM