Page MenuHomePhabricator

Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler with Extension:Math
Closed, DeclinedPublicBUG REPORT

Description

Dear Community,

I just created a mediawiki on my Hetzner Level 4 Webhosting Account.
As FTP client, I'm using FileZilla.
My mediawiki works perfectly.
Now I installed the maths extension.
However, when I try to edit my wikimediapages with something like this:

<math>\alpha</math>

I receive the following error:

MediaWiki internal error.

Original exception: [ca0d47bbd292f473763fca42] 2019-12-29 09:47:25: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

Exception caught inside exception handler.

Set $wgShowExceptionDetails = true; at the bottom of LocalSettings.php to show detailed debugging information.

Besides others, I have the following installed:

MediaWiki 1.34.0
PHP 7.3.13 (cgi-fcgi)
MySQL 5.7.28-1

Math 3.0.0 (b1a022f) 08:19, 30 September 2019 GPL-2.0-or-later Render mathematical formulas between <math> ... </math> tags Tomasz Wegrzanowski, Brion Vibber, Moritz Schubotz and Derk-Jan Hartman

I have tried several things, like using MediaWiki 1.33.1, log in/log out from accounts, etc. but I was not able to get the maths extension work sucessfully.

My workflow was as following:

  1. Download Maths-extension and upload unzipped "Math" folder via FTP server to "extensions" directory where my mediawiki is installed.
  2. Add
wfLoadExtension( 'Math' );

to LocalSettings.php

  1. Updated mediawiki via webbrowser (/mw-config/) as described here: https://www.mediawiki.org/wiki/Manual:Upgrading#Web_browser

Unfortunately, my Webhosting Account does not provide a command line input.

  1. Editing a page with a math command -- and there I received the error message as stated above.

I also can't access detailed error messages: As soon as I set $wgShowExceptionDetails = true; I get a blank page. I also tried to display other error messages, however I always receive a blank page.

For me it looks like some database connection regarding the math extension is broken.
I also wonder if the /mw-config/ update does its job correctly, e.g. I had to clear my browser history in order to be able to run the /mw-config/... It is really depending on your browser I think...

It seems like anything else works fine if I don't use <math>.

Has anybody a idea what I could have done wrong? Did I miss a step?

This report claims similar issues with blank pages I have:
https://www.mediawiki.org/wiki/Topic:Uosd6nlfwbkj001e
(However, they were able to fix the problem by running the update script, I can only run the updated script via /mw-config/ script as I have no command line input).

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 29 2019, 10:15 AM
Ammarpad renamed this task from MediaWiki internal error. Original exception: [ca0d47bbd292f473763fca42] 2019-12-29 09:47:25: Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler. Set $wgShowExceptionDetails = true; at the bottom of LocalSettings.php to show detailed debugging information. to Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler.Dec 29 2019, 10:24 AM
StefanEis renamed this task from Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler to MediaWiki internal error. Original exception: [ca0d47bbd292f473763fca42] 2019-12-29 09:47:25: Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler. Set $wgShowExceptionDetails = true; at the bottom of LocalSettings.php to show detailed debugging information..Dec 29 2019, 10:25 AM
StefanEis renamed this task from MediaWiki internal error. Original exception: [ca0d47bbd292f473763fca42] 2019-12-29 09:47:25: Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler. Set $wgShowExceptionDetails = true; at the bottom of LocalSettings.php to show detailed debugging information. to Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler.
StefanEis updated the task description. (Show Details)
StefanEis updated the task description. (Show Details)
StefanEis updated the task description. (Show Details)Dec 29 2019, 10:30 AM
StefanEis updated the task description. (Show Details)Dec 29 2019, 10:32 AM
StefanEis added a comment.EditedDec 29 2019, 11:11 AM

Dear Community,

Instead of using Extension:Math, I tried Extension:MathJax.

MathJax works without any issues. So I think there is somewhere a bug in Extension:Math, at least it doesn't work on my mediawiki.

Unfortunately, it seems like that VisualEditor is not supporting MathJax. However, Extension:Math and Extension:MathJax work together with Visual Editor.

Best,
Stefan

StefanEis added a comment.EditedDec 29 2019, 11:16 AM

Hi again,

I just tried Extension:Math together with the Visual Editor and I receive the following error:

[f7b04fe6216b742defdc1711] Exception caught: A database query error has occurred. This may indicate a bug in the software.

However, if you use Extension:Math and Extension:MathJax, then it works!

StefanEis renamed this task from Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler to Fatal exception of type "Wikimedia\Rdbms\DBQueryError" Exception caught inside exception handler with Extension:Math.Dec 29 2019, 11:39 AM
Physikerwelt changed the subtype of this task from "Task" to "Bug Report".Dec 29 2019, 12:32 PM
Physikerwelt moved this task from Incoming to Doing on the Math board.
Physikerwelt added a subscriber: Physikerwelt.

In it's default configuration Extension:Math does not use a database. There might be an issue in the interaction between Math and VisualEditor or Math and Wikibase. Can you provide more information on the error. Otherwise it will be hard to help here.

StefanEis added a comment.EditedDec 29 2019, 12:41 PM

Hi again,

I just took a look at Special:MathStatus

Math status
Jump to navigationJump to search
This page displays information about the enabled math rendering modes.
The following rendering modes are enabled:
PNG images
LaTeX source (for text browsers)
MathML with SVG or PNG fallback (recommended for modern browsers and accessibility tools)
Running backend tests for rendering mode MathML with SVG or PNG fallback (recommended for modern browsers and accessibility tools).
Test Rendering the input "x^2+\text{a sample Text}" succeeded.
Test Comparing to the reference rendering succeeded.
Test Rendering of a+b in plain MathML mode succeeded.
Test Checking the presence of '+' in the MathML output succeeded.
Test Comparing the generated SVG with the reference failed.
Test Checking if MathML input is supported succeeded.
Test Rendering Presentation MathML sample failed.
Test Checking if the link to SVG image is correct failed.
Returned string
<strong class='error texerror'>Failed to parse (): {\displaystyle &lt;msub&gt; &lt;mrow&gt; &lt;mi&gt; P&lt;/mi&gt; &lt;/mrow&gt; &lt;mrow&gt; &lt;mi&gt; i&lt;/mi&gt; &lt;mi&gt; j&lt;/mi&gt; &lt;/mrow&gt; &lt;/msub&gt; &lt;mo&gt; =&lt;/mo&gt; &lt;mfrac&gt; &lt;mrow&gt; &lt;mn&gt; 100&lt;/mn&gt; &lt;msub&gt; &lt;mrow&gt; &lt;mi&gt; d&lt;/mi&gt; &lt;/mrow&gt; &lt;mrow&gt; &lt;mi&gt; i&lt;/mi&gt; &lt;mi&gt; j&lt;/mi&gt; &lt;/mrow&gt; &lt;/msub&gt; &lt;/mrow&gt; &lt;mrow&gt; &lt;mn&gt; 6.75&lt;/mn&gt; &lt;msub&gt; &lt;mrow&gt; &lt;mi&gt; r&lt;/mi&gt; &lt;/mrow&gt; &lt;mrow&gt; &lt;mi&gt; j&lt;/mi&gt; &lt;/mrow&gt; &lt;/msub&gt; &lt;/mrow&gt; &lt;/mfrac&gt; &lt;mo&gt; ,&lt;/mo&gt; &lt;/math&gt;}</strong>
does not contain expected string
hash=5628b8248b79267ecac656102334d5e3&amp;mode=mathml
.
Backend tests for rendering mode MathML with SVG or PNG fallback (recommended for modern browsers and accessibility tools) completed.

In it's default configuration Extension:Math does not use a database. There might be an issue in the interaction between Math and VisualEditor or Math and Wikibase. Can you provide more information on the error. Otherwise it will be hard to help here.

Hi Physikerwelt,

the problem is still there whether I have VisualEditor installed or not.
So as you say there might be an issue with Math and Wikibase.

I the case of VisualEditor, I noticed that the formula is also not presented visually:

@StefanEis the failure in "Comparing the generated SVG with the reference failed." is not severe. I also happens on Wikipedia https://en.wikipedia.org/wiki/Special:MathStatus

Is your wiki public? Would like to share a link?

StefanEis added a comment.EditedDec 30 2019, 4:22 PM

Hi,

I added $wgShowExceptionDetails = true; in LocalSettings.php but this leads only to a white page without showing any error at all.

It seems like that it is not possible to add a debug command in the LocalSettings.php.
Anything I add regarding debugging will lead to a blank page as stated above.

Maybe this is the reason for a blank page:

A blank page generally means PHP crashes before it can execute a line of code. It can't write a log file.

(from:
Math extension cause a fatal exception of type "Wikimedia\Rdbms\DBQueryError"
, also https://www.mediawiki.org/wiki/Manual:Errors_and_symptoms#You_see_a_Blank_Page)

Physikerwelt moved this task from Doing to Incoming on the Math board.Feb 9 2020, 1:40 PM
Aklapper changed the task status from Open to Stalled.Feb 28 2020, 1:43 PM

Unfortunately nothing can be done without a stacktrace, hence setting status to stalled.

Aklapper closed this task as Declined.Wed, Mar 25, 4:08 PM

Unfortunately closing this Phabricator task as no further information has been provided. @StefanEis: After you have provided a stacktrace for and if this still happens, please set the status of this task back to "Open" via the Add Action...Change Status dropdown. Thanks!