Page MenuHomePhabricator

S5SlideShow extension does not work anymore with Mediawiki 1.33+
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:

http://royal-family.bitplan.com/index.php/WikiCMS

Actual Results:

[7bf3aa23dffbe717bf0b4739] /index.php?title=WikiCMS&action=submit Error from line 57 of /var/www/mediawiki/code/extensions/S5SlideShow/S5SlideShow.class.php: Call to undefined method Article::getContent()

Backtrace:

#0 /var/www/mediawiki/code/extensions/S5SlideShow/S5SlideShow.class.php(534): S5SlideShow->__construct(Title, NULL, array)
#1 /var/www/mediawiki/code/includes/parser/Parser.php(4000): S5SlideShow::slideshow_view(string, array, Parser, PPFrame_DOM)
#2 /var/www/mediawiki/code/includes/parser/Preprocessor_DOM.php(1370): Parser->extensionSubstitution(array, PPFrame_DOM)

Expected Results:

Page storable and slideshow extension working.

Links:

I am also trying to contact the author Vitaliy Filippov

Event Timeline

Seppl2013 created this task.Jan 2 2020, 6:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 2 2020, 6:56 AM
Aklapper closed this task as Invalid.Jan 2 2020, 2:51 PM

S5Slideshow does not use Wikimedia Phabricator to track issues. Please report this to https://github.com/mediawiki4intranet/S5SlideShow/issues instead. Thanks!

So what's the replacement for Article:getContent()?

https://doc.wikimedia.org/mediawiki-core/1.27.1/php/classArticle.html#ada2a8ad4388950b06cd2dc563375aa22 says "Deprecated since 1.21; use WikiPage::getContent() instead"

@Aklapper - @Hexmode and I are working on a fix for the extension. I think we need to move the repository. Could we get an official Wikimedia repository an Phabricator project for this extension please ...

For the time being there is http://wiki.bitplan.com/index.php/S5SlideShow with info on the state of affairs

I think we need to move the repository. Could we get an official Wikimedia repository an Phabricator project for this extension please ...

@Seppl2013: Hi, see https://www.mediawiki.org/wiki/Phabricator/Creating_and_renaming_projects and https://www.mediawiki.org/wiki/Gerrit/New_repositories/Requests

Seppl2013 added a comment.EditedFeb 14 2020, 4:20 PM

I tried a request https://www.mediawiki.org/wiki/Gerrit/New_repositories/Requests and now a question showed up there and i have no clue how to answer it since the edit button does some magic and there is only a request but no reply or anything.

Hello Seppl2013. Is the code you'd like us to import for a MediaWiki extension or something else? Thanks. —MarcoAurelio (talk) 15:37, 14 February 2020 (UTC)

@MarcoAurelio - the context of your question is explained in this task here.

I tried a request https://www.mediawiki.org/wiki/Gerrit/New_repositories/Requests and now a question showed up there and i have no clue how to answer it since the edit button does some magic and there is only a request but no reply or anything.

Indeed, confusing. Probably at the bottom of https://www.mediawiki.org/w/index.php?title=Gerrit/New_repositories/Requests/Entries&action=edit

Thanks for the ping @Seppl2013. I'll go ahead and create/import the repo shortly. @Aklapper I think the process might be a bit confusing indeed. I've proposed at https://www.mediawiki.org/wiki/Topic:Uqfdno10snrrfmc0 that requests for gerrit repos be moved from mw.org to Phabricator some time ago. While I've no problems processing requests for creating repos here at Phab or there at mw.org; ideally we should have an unique, centralized place so admins/managers get to watch one single place. Thanks.

Repo created and imported as requested. If you intend to use Phabricator for bug tracking, I'll be more than happy to create a project for S5SlideShow. Thanks.